Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите написать программу в паскале!Очень надо!

10-11 класс

Задана последовательность целых чисел,количество которых не превосходит 100.Требуется определить за один проход элемент с максимальным значением,а также число его повторений в последовательности.

Karamelshark 02 нояб. 2014 г., 2:20:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Korobtschuk
02 нояб. 2014 г., 4:48:21 (9 лет назад)

program maxof;
var ar: array [1..100] of integer;
i, j, posl: shortint;
max: integer;
begin
readln(i);

+ 0 -
Adelka11
02 нояб. 2014 г., 6:52:02 (9 лет назад)

var
  i,k,max:integer;
  a:array[1..100]of integer;
begin
writeln('Исходная последовательность: ');
for i:=1 to 100 do
  begin
  a[i]:=random(200);
  write(a[i],' ');
  if a[i]>max then
    begin
    max:=a[i];
    k:=1;
    end;
  if a[i]=max then
    k:=k+1;
  end;
writeln;
writeln('Максимальное значение: ',max);
writeln('Число повторений: ',k)
end.

+ 0 -
Vasiljeva1998
02 нояб. 2014 г., 8:54:54 (9 лет назад)

использовать массив?

+ 0 -
Aliysha97
02 нояб. 2014 г., 9:59:58 (9 лет назад)

да,можно)

+ 0 -
Potterovna
02 нояб. 2014 г., 12:25:45 (9 лет назад)

Хорошо, сейчас сделаю

+ 0 -
RomaNikolaev
02 нояб. 2014 г., 13:27:02 (9 лет назад)

буду очень признательна)

+ 0 -
Hamster1605
02 нояб. 2014 г., 15:46:01 (9 лет назад)

А обязательно 100? Весь экран займут)))

Ответить

Читайте также

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.



Вы находитесь на странице вопроса "Помогите написать программу в паскале!Очень надо!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.