Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Здравствуйте ребят! Помогите решить задачку..Мне её надо написать в С++. Честно говоря хотя бы напишите мне "Дано" и как это решить. На

10-11 класс

острове каждый год появляется сундук с 100 кг золотого песка, к острову с одной стороны высаживается х пиратов, а с другой у матросов. Они дерутся за клад, в битве погибает 70% участников, 26% тяжело ранены. Монеты делятся среди оставшихся 4%. Определить количество победителей, тяжелораненых, погибших, а также количество золотого песка на 1 человека .

Sacsha140997 28 июня 2014 г., 6:05:25 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Колямба88Студент
28 июня 2014 г., 6:53:10 (9 лет назад)

Чес гря не понимаю, в чем заморочка... Тут же все указано. Безо всЯкого С++ в экселе мона сотворить этакий "калькулятор"))

 

есть постоянная 100 (гк золота)

и переменные Х и У, их вводит, я так понял, пользователь программулечки,

дальше сии переменные суммируются

и из них считают

70% - результат сообщают польщователю с пометкой "погибшие"

26% результат сообщают польщователю с пометкой "тяжело ранено"

4% результат сообщают польщователю с пометкой "Осталось в живых"

а постоянную100 делят на эти 4% от Х+У ( то есть на к-во выживших) и сообщают результат пользователю с пометкой "досталось золота каждому из них (выживших)"

 

затем, если надо, обнулить Х и У для следкющего года. 

А результаты, если надо получить данные за два года, прибавлять к предыдущим, уже посчитанным... Ну и еще куча вариантов обработки результатов... Вдруг нужна выборка по четным годам, вдруг еще чего)))

 

 мона поставить переменную, считающую годы с каждым вводом Х и У...

 

 

В ощем - подвинтеся, дайте простор моей фантазии!))

 

 

Ответить

Читайте также

Здравствуйте ребят! Помогите решить задачку..Мне её надо написать в С++. Честно говоря хотя бы напишите мне "Дано" и как это решить.

=)

На концерте певицы было А % отдыхающих в санатории, на выступление хора зрителей собралось в 1,5 раза больше. Сколько зрителей побывало на этих концертах, если всего в санатории отдыхало х человек.

Помогите решить задачку очень-очень надо:)) спасибо:* Устав от повседневных дел, Иван Петрович устроил себе отпуск - пошел на охоту. На

расстоянии N метров, его охотничья собака Гайзарда заметила зайца. Через какое время она догонит его если скорость зайца V1 м / с, а скорость собаки V2 м / с? Следует отметить, что Гайзарда бегает быстрее любого зайца.
Входные данные:
Программа на вход получает три целых числа N, V1, V2 (0 ≤ N ≤ 103, 0 <V1, V2 <20).
Выходные данные:
Программа должна вывести время за собака догонит зайца с точностью до сотых.

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

Здравствуйте, прошу помогите решить такое вот чудо.

Решить вроде бы нужно найти что за число вместо x.
Кто знает как правильнее прошу вашей помощи.
Чтобы просмотреть фото, кликните на него.



Вы находитесь на странице вопроса "Здравствуйте ребят! Помогите решить задачку..Мне её надо написать в С++. Честно говоря хотя бы напишите мне "Дано" и как это решить. На", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.