Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Написать прогу на паскале. Дано натуральное число n. Вычислить y=2*4*6...(2n).

10-11 класс

Neznyka 26 апр. 2014 г., 8:27:35 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vituwastoilov
26 апр. 2014 г., 11:09:02 (10 лет назад)

Program Program1;
var
i,n,y:integer;
begin
write('Введите значение n: ');
readln(n);
i:=2;
y:=1;
while i<=2*n do
begin
y:=y*i;
inc(i,2);
end;
writeln('y=',y);
end.

Ответить

Читайте также

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

СРОЧНО ПЛИИИЗ Задача: Дано действительное число Х, вычислить

(x-1)(x-3)(x-7)...(x-63)/(x-2)(x-4)(x-8)...(x-64) (дробь)

Используя оператор: while
Не могу написать через данный оператор программу на паскаль, выходит всегда число 0. Прошу помочь мне :)

Помогите, пожалуйста написать программу на паскаль

Дано натуральное число. Вычислить количество цифр, являющихся степенями тройки (1,3,9).



Вы находитесь на странице вопроса "Написать прогу на паскале. Дано натуральное число n. Вычислить y=2*4*6...(2n).", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.