Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

ребята нужна помощь,очень важно в turbopascal решить занести в файл 3 записи,каждая из которых представляет

10-11 класс

собой совокупность трех полей:фамилия ,год рождения,женат или нет

Иванов 1970 да

Петров 1972 нет

Сидоров 1969 да.

распечатать содержимое полученного файла

Затем считать из файла эту информацию и напечатать:

1-я запись-Иванов 1970 да

2-я запись-Петров 1972 нет

3-я запись-Сидоров 1969 да

Lad12345675 14 марта 2015 г., 5:51:10 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Shurakov
14 марта 2015 г., 7:10:05 (9 лет назад)

Program Pr1;
uses crt;
var stroka:string;
fl1:text;
i,n:integer;
Begin
clrscr;
assign(fl1,'output.txt');
writeln('Введите количество фамилий');
readln(n);
append(fl1);
for i:=1 to n do begin
writeln('Введите фамилию,год рождения, женат или нет');
readln(stroka);
writeln(fl1,stroka);
end;
close(fl1);
stroka:='';
reset(fl1);
for i:=1 to n do begin
readln(fl1,stroka);
writeln('',i,'-ая запись-',stroka);
stroka:='';
end;
close(fl1);
end.

 

Ответить

Другие вопросы из категории

Массив F заполнен кубами первых 10 натуральных чисел. Вставить на 3 место квадрат количества элементов в массиве. В получившемся массиве удалить

последовательно пятый и восьмой элементы. Программу требуется написать в Pascal.

PASCAL

С клавиатуры последовательно вводятся 10 чисел найти ср. арифметическое четных чисел

Вспомните по одному объекту каждого из приведенных множеств и запишите их единичные имена.

1.Остров
2. Мореплаватель
3.Орфограмма
4.Математический закон
5.Формула
6.Поэма
Пожалуйста, срочно надоо.!))

Читайте также

Помогите, пожалуйста, решить задачи.

1. В один из жарких летних дней Петя и его друг Вася решили купить арбуз. Они выбрали самый большой и самый спелый, на их взгляд. После недолгой процедуры взвешивания весы показали w килограмм. Поспешно прибежав домой, изнемогая от жажды, ребята начали делить приобретенную ягоду, однако перед ними встала нелегкая задача. Петя и Вася являются большими поклонниками четных чисел, поэтому хотят поделить арбуз так, чтобы доля каждого весила именно четное число килограмм, при этом не обязательно, чтобы доли были равными по величине. Ребята очень сильно устали и хотят скорее приступить к трапезе, поэтому Вы должны подсказать им, удастся ли поделить арбуз, учитывая их пожелание. Разумеется, каждому должен достаться кусок положительного веса.
Входные данные
В первой и единственной строке входных данных записано целое число w (1 ≤ w ≤ 100) — вес купленного ребятами арбуза.
Выходные данные
Выведите YES, если ребята смогут поделить арбуз на две части, каждая из которых весит четное число килограмм, и NO в противном случае.
Примечание
Например, ребята могут поделить арбуз на две части размерами 2 и 6 килограммов соответственно (другой вариант — две части 4 и 4 килограмма).

2. На клетчатой плоскости заданы координаты K зданий. Требуется построить кольцевую дорогу вокруг зданий минимальной длины в виде прямоугольника, со сторонами, параллельными линиям сетки.
Входные данные
Во входном файле, на первой строке, находится число K( ). На следующих K строках находятся пары чисел и – координаты зданий
( ).
Выходные данные
Выведите в выходной файл координаты левого нижнего и правого верхнего углов прямоугольника.

3. Хакер Иван является сотрудником крупной антивирусной компании. Один из вирусов исследованием, которого он занимается, был специально создан для атаки на программы биржевой торговли.
Для того что бы победить зловред Ване необходимо разработать алгоритм, который бы вычислил минимальное количество операций необходимых для того что бы пара чисел (a, b) стала "k -красивой". Пара чисел (a, b) называется "k-красивой" если хотя бы одно из чисел парны не меньше заданного целого числа k. При этом, операции, проводимые с парой чисел (a, b) могут быть только такие:
1. Пара (a, b) может быть преобразована в (a+b, b);
2. Пара (a, b) может быть преобразована в (a, b+a).
Помогите Ване победить.
Входные данные
Единственная строка входных данных содержит три целых числа a, b и k ( - 1018 ≤ x, y, m ≤ 1018).
Выходные данные
Выведите минимальное количество операций или число -1, если сделать заданную пару "k-красивой" невозможно.

4. Инженер-программист Надежда занимается разработкой компилятора для нового сверх секретного языка программирования. Для того чтобы закончить разработку одного из модулей ей остается решить задачу следующего содержания:
Во входных данных Надя получает строку содержащую в себе цифры и скобки одного вида: '(' и ')'. Наде необходимо написать программу, которая для любых входных данных определяет является ли содержащаяся в них скобочная последовательность правильной, и в случае правильности скобочной последовательности возвращает количество встречающихся в ней скобок, если же последовательность неправильная, то выводится число -1.
Скобочная последовательность называется правильной, если:
1. Пустая строка — правильная скобочная последовательность;
2. Правильная скобочная последовательность, взятая в скобки одного типа — правильная скобочная последовательность;
3. Правильная скобочная последовательность, к которой приписана слева или справа правильная скобочная последовательность — тоже правильная скобочная последовательность.
Помогите Наде в разработке компилятора для нового сверх секретного языка программирования.
Входные данные
Единственная строка конечной длины содержит цифры и скобки, длина строки не больше 1024 символов.
Выходные данные
Выведите количество скобок если скобочная последовательность правильная или число -1 если нет.

5. Маленький Вася научился считать сумму цифр для любого числа. Для любого числа, он считал сумму его цифр, затем тоже самое он делал с полученным в результате числом и так далее. Определите сколько раз Васе необходимо посчитать сумму, чтобы она стала цифрой.
Входные данные
Одна непустая строка с числом (0 Выходные данные
Одна строка, с числом.

Нужна помощь,очень-очень

В содержание спецификации программы не входит
1.описание класса входных данных
2.формулировка задачи
3.описание алгоритма решения задачи
4.описание формы представления результатов

Ребят,срочно срчно хелп!!!

Помогите решить Д/З по ИКТ

1.считая,что каждый символ кодируется одним байтом,оцените информационный объём следующего предложения в одном килограмме 1000 грамм

2.В бассейне ведётся наблюдение за температурой воды. результатом одного измерения является целое число от +10 до +35 градусов,которое записывается при помощи минимального количества бит. Было сделано 27 измерений. Определите информационный объем всех результатов наблюдений

3.Световое табло состоит из лампочек,каждая из которых находится в одном из двух состояний("Включено" или "Выключено"). Какое наименьшее количество лампочек должно находиться на табло,чтобы с помощью его можно было передать 200 различных сигналов?

Два товарища Миша и Петр пошли в тир. Они стреляют по мишенях, которые расположены в один ряд. Миша стреляет по мишенях с лева направо, а Петр с права

налево.В какой то момент времени случилось так, что они попали в одну мишень. После этого они остановились и решили посчитать, во сколько мишеней каждый из них не стрелял. М и Р - количество мишеней, в какие попали Миша и Петр соответственно.
М+Р меньше или равняется 100
Нужно найти два числа - количество мишеней в какие не стреляли Миша и Петр.



Вы находитесь на странице вопроса "ребята нужна помощь,очень важно в turbopascal решить занести в файл 3 записи,каждая из которых представляет", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.