Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Всем привет! Помогите пожалуйста по информатике. Задача: ввести целое число и найти сумму его цифр. Пример: введите целое число:1234. Сумма цифр числа 1

10-11 класс

234 равна 10. Задача: сумма цифр ввести целое число и определить верно ли, что в его записи есть 2 одинаковые цифры. Пример: введите целое число 1234 нет введите целое число 1224 да

Настя2307 21 июля 2014 г., 12:32:38 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Natali9170
21 июля 2014 г., 14:12:16 (9 лет назад)

1) 

a,s,i: integer;

read(a);

s:=0

while a>0 do

begin

s:=s+a mod 10;

a:=a div 10;

end;

write(s);

end.

2) 

a,s,i,m(9): integer;

read(a);

s:=0

while a>0 do

begin

m(a mod 10):=m(a mod 10)+1

a:=a div 10;

end;

for i=0 to 9 do begin

if m(i)=2 then

write('Есть'');

end;

end.

Ответить

Другие вопросы из категории

Составить программу в паскале с использованием циклических операторов:

три приятеля математика были свидетелями дорожного происшествия. Номер машины(четырехзначный) ни один из них не запомнил. Однако один заметил,что этот номер делиться на 2,7 и 11; другой заметил, что в номере учавствуют только две цифры, а третий заметил,что сумма цифр равна 30 . Какой номер автомобиля?

Составить алгоритм и соответствующую ему программу для определения максимального элемента в таблице А[1..N]. Определить величину этого элемента и его но

мер в таблице.Произвести отладку и проверить работу программы для произвольно заданных элементов таблицы. ПОЖАЛУЙСТА ПОМОГИТЕ ХОТЬ ПРОГРАММУ СОСТАВИТЬ!!! СРОЧНО)

Читайте также

Помогите, пожалуйста, решить задачи.

1. В один из жарких летних дней Петя и его друг Вася решили купить арбуз. Они выбрали самый большой и самый спелый, на их взгляд. После недолгой процедуры взвешивания весы показали w килограмм. Поспешно прибежав домой, изнемогая от жажды, ребята начали делить приобретенную ягоду, однако перед ними встала нелегкая задача. Петя и Вася являются большими поклонниками четных чисел, поэтому хотят поделить арбуз так, чтобы доля каждого весила именно четное число килограмм, при этом не обязательно, чтобы доли были равными по величине. Ребята очень сильно устали и хотят скорее приступить к трапезе, поэтому Вы должны подсказать им, удастся ли поделить арбуз, учитывая их пожелание. Разумеется, каждому должен достаться кусок положительного веса.
Входные данные
В первой и единственной строке входных данных записано целое число w (1 ≤ w ≤ 100) — вес купленного ребятами арбуза.
Выходные данные
Выведите YES, если ребята смогут поделить арбуз на две части, каждая из которых весит четное число килограмм, и NO в противном случае.
Примечание
Например, ребята могут поделить арбуз на две части размерами 2 и 6 килограммов соответственно (другой вариант — две части 4 и 4 килограмма).

2. На клетчатой плоскости заданы координаты K зданий. Требуется построить кольцевую дорогу вокруг зданий минимальной длины в виде прямоугольника, со сторонами, параллельными линиям сетки.
Входные данные
Во входном файле, на первой строке, находится число K( ). На следующих K строках находятся пары чисел и – координаты зданий
( ).
Выходные данные
Выведите в выходной файл координаты левого нижнего и правого верхнего углов прямоугольника.

3. Хакер Иван является сотрудником крупной антивирусной компании. Один из вирусов исследованием, которого он занимается, был специально создан для атаки на программы биржевой торговли.
Для того что бы победить зловред Ване необходимо разработать алгоритм, который бы вычислил минимальное количество операций необходимых для того что бы пара чисел (a, b) стала "k -красивой". Пара чисел (a, b) называется "k-красивой" если хотя бы одно из чисел парны не меньше заданного целого числа k. При этом, операции, проводимые с парой чисел (a, b) могут быть только такие:
1. Пара (a, b) может быть преобразована в (a+b, b);
2. Пара (a, b) может быть преобразована в (a, b+a).
Помогите Ване победить.
Входные данные
Единственная строка входных данных содержит три целых числа a, b и k ( - 1018 ≤ x, y, m ≤ 1018).
Выходные данные
Выведите минимальное количество операций или число -1, если сделать заданную пару "k-красивой" невозможно.

4. Инженер-программист Надежда занимается разработкой компилятора для нового сверх секретного языка программирования. Для того чтобы закончить разработку одного из модулей ей остается решить задачу следующего содержания:
Во входных данных Надя получает строку содержащую в себе цифры и скобки одного вида: '(' и ')'. Наде необходимо написать программу, которая для любых входных данных определяет является ли содержащаяся в них скобочная последовательность правильной, и в случае правильности скобочной последовательности возвращает количество встречающихся в ней скобок, если же последовательность неправильная, то выводится число -1.
Скобочная последовательность называется правильной, если:
1. Пустая строка — правильная скобочная последовательность;
2. Правильная скобочная последовательность, взятая в скобки одного типа — правильная скобочная последовательность;
3. Правильная скобочная последовательность, к которой приписана слева или справа правильная скобочная последовательность — тоже правильная скобочная последовательность.
Помогите Наде в разработке компилятора для нового сверх секретного языка программирования.
Входные данные
Единственная строка конечной длины содержит цифры и скобки, длина строки не больше 1024 символов.
Выходные данные
Выведите количество скобок если скобочная последовательность правильная или число -1 если нет.

5. Маленький Вася научился считать сумму цифр для любого числа. Для любого числа, он считал сумму его цифр, затем тоже самое он делал с полученным в результате числом и так далее. Определите сколько раз Васе необходимо посчитать сумму, чтобы она стала цифрой.
Входные данные
Одна непустая строка с числом (0 Выходные данные
Одна строка, с числом.

4 задачи: ввести натуральное число и определить, верно ли, что сумма цифр равна 10 (через repeat и until)//// ввести натуральное

число и определить, какие цифры встречаются несколько раз (через repeat и until)///

ввести целое число и найти сумму его цифр (через while)

ввести целое число и определить , верно ли, что в его записи есть две одинаковые цифры(через while)

всё через паскаль абс

Помогите пожалуйста!

1.С клавиатуры вводится целое двузначное число.Вывести на экран сумму его цифр.
2.Найти все двузначные числа,в которых есть цифра 4.
Прошу,помогите.



Вы находитесь на странице вопроса "Всем привет! Помогите пожалуйста по информатике. Задача: ввести целое число и найти сумму его цифр. Пример: введите целое число:1234. Сумма цифр числа 1", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.