Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

В введенной строке подсчитать количество слов, что одинаково начинаются и заканчиваются

10-11 класс

(Примечание: Слова в текстовой строке отделены пробелами или группами пробелов.

Kostyabochkare 20 апр. 2014 г., 2:41:21 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Polina25zero05
20 апр. 2014 г., 3:42:04 (10 лет назад)

program z_string; 
uses crt; 
const Letters = ['a'..'z','A'..'Z','а'..'я','А'..'Я']; 
var StringS, Symbol :string; 
     CounterI, Number:byte; 
begin

 clrscr; 
 writeln('Введите строку текста'); 
 readln(StringS); 
  
 Number := 0; 
 Symbol := ''; 
for CounterI := 1 to length(StringS) do 
 begin 
  if (StringS[CounterI] in Letters) and (Symbol = '') then 
   Symbol := StringS[CounterI]; 
    
  if (not(StringS[CounterI] in Letters)) and (CounterI <> 1) then 
  begin 
   if StringS[Counteri - 1] = Symbol then 
    inc(Number); 
   Symbol := '';
  end; 
   
  if (CounterI = length(StringS)) and (StringS[CounterI] = Symbol) then 
   inc(Number); 
 end; 
  
 writeln; 
 writeln('Количество слов начинающихся и заканчивающихся одной и той же буквой ', Number); 
 readln; 
end.

ахах тоже составляли такую,прикольная;)

 

+ 0 -
ZLOIKOT
20 апр. 2014 г., 5:10:18 (10 лет назад)

var

Ответить

Другие вопросы из категории

ПОМОГИТЕ!

Слова которые пишутся одинаково,но имеют разное значения.Помогите наведите примеры.(коса,замок,журавель не подойдут)

что такое система исчисления
1)переведите в десятичную систему исчесления

3E,B2(16 снизу)>>X(10 снизу)
1011,1101(2 снизу)>>X(10 снизу)
415,37(8 снизу)>>X(10 снизу)
помогите плиз

Читайте также

Даны натуральное число n, символы s1,...sn. , группы символов, разделённые пробелами (одним или несколькими) и не содержащие пробелов внутри себя ,

будем называть словами. подсчитать количество слов в данной последовательности.

в TPascal

Помогите в с++ билдер. В строке, состоящей из групп нулей и единиц, подсчитать количество символов в самой длинной группе.(напишите код в консоли)...

вот пример который считает количество едениц в строках с нечётным количеством символов
//---------------------------------------------------------------------------

#include
#include
#include
#include
#pragma hdrstop

//---------------------------------------------------------------------------

#pragma argsused
int main(int argc, char* argv[])
{
int n,s, i, nst,p,k, len,t=0;
char a[81];
puts(" Input string ");
gets(a);
len = strlen(a);
s=0;
n=0;
a[len+1]='\0';
a[len]=' ';
for(i=0; i<=len; i++)
{
if(a[i]!=' ')
{
n++;
if(a[i]=='1')
t++;
}
else
{
if(n%2!=0)s+=t;
n=0;
t=0;
}
}
printf("\nkoli4ectvo 1= %d", s);
puts("\nPress any key to close ... ");
getch();
return 0;
}
//---------------------------------------------------------------------------

1)Вывести в обратном порядке второе слово строки. Подсчитать количество букв в нем.

2) Составить программу для вычисления Т=(R/Q+1)+S. R - наименьший элемент массива;
Q - произведение элементов массива с нечетными номерами;
S - количество элементов, лежащих в интервале (A,B) (ввести с клавиатуры).
3) Вычислить среднее арифметическое положительных элементов матрицы, расположенных ниже
побочной диагонали. Закрасить указанные элементы.

5.1 Ввести

с клавиатуры строку символов. Признак окончания ввода строки – нажатие клавиши
"Ввод". Программа должна определить длину введенной строки L, и, если
длина L >6, то выделяется подстрока в { } скобках.



5.2 Дана
строка. Подсчитать количество букв k в последнем его слове.



Вы находитесь на странице вопроса "В введенной строке подсчитать количество слов, что одинаково начинаются и заканчиваются", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.