Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дано трехзначное число. Определить, какая из его цифр

5-9 класс

больше:
а) первая или последняя;
б) первая или вторая;
в) вторая или последняя.

РЕШИТЬ на Visual Studio

Nuskova1 27 янв. 2014 г., 10:00:15 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nina302009nj
27 янв. 2014 г., 12:32:02 (10 лет назад)

Program Digit;
Var a, a1, a2, a3: Integer;
Label Start;
Begin
Start:
WriteLn('Введите трехзначное число');
ReadLn(a);
If (a < 100) Or (a > 999) Then
Begin
WriteLn('Вы ввели не трехзначное число');
Goto Start;
End;
a1 := a div 100;
a2 := (a - a1 * 100) div 10;
a3 := a - a1 * 100 - a2 * 10;
If a1 > a3 ThenWriteLn('Первая цифра больше последней')
Else
Writeln('Последняя цифра больше первой');
If a1 > a2 Then
WriteLn('Первая цифра больше второй')
Else
Writeln('Вторая цифра больше первой');
If a2 > a3 Then
WriteLn('Вторая цифра больше последней')
Else
Writeln('Последняя цифра больше второй');
ReadLn;
End.

Ответить

Другие вопросы из категории

Помогите сложить числа

(2) - это двоичная система

а) 11100000(2)+1100000000(2); б) 110101101(2)+111111110(2); в) 10011011,011(2)+1110110100,01(2); г) 1041,2(8)+1141,1(8); д) 3C6,8(16)+B7,5(16

Не­ко­то­рый ал­го­ритм из одной це­поч­ки сим­во­лов по­лу­ча­ет новую це­поч­ку сле­ду­ю­щим об­ра­зом. Сна­ча­ла вы­чис­ля­ет­ся длина ис­ход­ной

це­поч­ки сим­во­лов; если она нечётна, то уда­ля­ет­ся сред­ний сим­вол це­поч­ки, а если чётна, то в конец це­поч­ки до­бав­ля­ет­ся сим­вол У. В по­лу­чен­ной це­поч­ке сим­во­лов каж­дая буква за­ме­ня­ет­ся бук­вой, сле­ду­ю­щей за ней в рус­ском ал­фа­ви­те (А — на Б, Б — на В и т. д., а Я — на А). По­лу­чив­ша­я­ся таким об­ра­зом це­поч­ка яв­ля­ет­ся ре­зуль­та­том ра­бо­ты ал­го­рит­ма.На­при­мер, если ис­ход­ной была це­поч­ка РУКА, то ре­зуль­та­том ра­бо­ты ал­го­рит­ма будет це­поч­ка СФЛБФ, а если ис­ход­ной была це­поч­ка СОН, то ре­зуль­та­том ра­бо­ты ал­го­рит­ма будет це­поч­ка ТО.

Помогите пожалуйста

Срочно


Читайте также

Напишите программу на паскале)

1.С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше.
2.С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом.
3.С клавиатуры вводится 4-хзначное число. Определить, равна ли сумма первых двух цифр сумме последних двух.

1.Определите,какое из указанных имен файлов удовлетворяет маске: A?ce*s.m*

1)Acess.md 2)Accesst.dbf 3)Access.mdb 4)Akcces.m1
2.Определите,какое из указанных имен файлов не удовлетворяет маске: ??pri*.?*
1)caprika.wow 2)weprik.cpp 3)otopri.c 4)reprint.be



Вы находитесь на странице вопроса "Дано трехзначное число. Определить, какая из его цифр", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.