Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дано натуральное число. Определить, какое из его цифр больше: первая или последняя.

5-9 класс

Гнутый 09 февр. 2014 г., 6:26:03 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Danilovakiss22
09 февр. 2014 г., 7:22:07 (10 лет назад)

первое 1последние бесконечное

+ 0 -
Kevin9889
09 февр. 2014 г., 9:28:46 (10 лет назад)

Pascal:
var n,b:longint;
begin
  write('N = ');
  readln (n);
  b:=n mod 10;
  while (n div 10 <> 0) do n:=n div 10;
  if n>b then writeln ('First!') else
    if b>n then writeln ('Second!') else writeln ('First and Second equal!');
end.

C++:
#include <iostream>
using namespace std;

int main()
{
  int n,a;
  cout <<"N = ";
  cin >>n;
  a = n%10;
  while (n/10!=0)
    n/=10;
  if (n>a)
    cout <<"First!" <<endl;
  else if (a>n) cout <<"Second!" <<endl;
  else cout <<"First and Second equal" <<endl;
  return 0;
}

Ответить

Читайте также

Напишите программу на паскале)

1.С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше.
2.С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом.
3.С клавиатуры вводится 4-хзначное число. Определить, равна ли сумма первых двух цифр сумме последних двух.

Дано трехзначное число. Определить, какая из его цифр

больше:
а) первая или последняя;
б) первая или вторая;
в) вторая или последняя.

РЕШИТЬ на Visual Studio

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!



Вы находитесь на странице вопроса "Дано натуральное число. Определить, какое из его цифр больше: первая или последняя.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.