Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Сформировать массив из n случайных чисел на промежутке [-50;50].Найти сумму четных чисел.

10-11 класс

Rasid13 18 апр. 2015 г., 6:55:37 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Agbanova80
18 апр. 2015 г., 9:29:07 (9 лет назад)

program Project2;
{$APPTYPE CONSOLE}
uses  Windows;
var n,i,s:integer;    a:array of Integer;
begin 
randomize;
s:=0; 
SetConsoleOutputCP(1251);
 write('Введите длину массива: '); 
readln(n); 
SetLength(a,n); 
for i:=0 to Length(a) do 
 a[i]:=Random(100)-50; 
for i:=0 to Length(a) do
  write(a[i]:3); 
 writeln; 
for i:=0 to Length(a) do 
 if a[i] mod 2 =0 then 
 s:=s+a[i]; 
writeln('Сумма: ',s);
 Readln;
end.

Ответить

Другие вопросы из категории

Составить программу на языке Паскаль

Известна температура больного за 20 дней пребывания в больнице. Можно ли еговыписывать, если для этого требуется, чтобы не менее половины всех дней, когда у негобыла температура ниже 37°, приходилось на вторую половину его пребывания вбольнице?

Наташа набрала текст на компьютере. Текст получился на 12 страниц, каждая страница состоит 24 строк, в каждой строчке 21 символ. Определите информационный

объём получившегося текста в одной из кодировок Unicode, в которой каждый символ кодируется 16 битами.

Помогите написать программу для вычисления примера:

y=cos(v)* \sqrt[3]{1+ sin^{2}(v+a) } ; v=(a+c)/a*c; a= e^{-c} +c; c=2.35

Или хотя бы ход решения, какие операторы использовать и т. п.

Читайте также

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива

2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.



Вы находитесь на странице вопроса "Сформировать массив из n случайных чисел на промежутке [-50;50].Найти сумму четных чисел.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.