Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Задача на Паскале(нужно полное решение)

5-9 класс

Задан массив случайным образом. Преобразовать его след. образом:

Jonas099 01 февр. 2014 г., 15:46:49 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dimandiman
01 февр. 2014 г., 18:18:44 (10 лет назад)

var A: array [1..100] of integer;

i: integer;

begin

randomize;

for i := 1 to 100 do begin

A[i] := random(200) - 100;

end;

for i := 1 to 100 do begin

if (A[i] < 0) then A[i] := Abs(A[i]);

else if (A[i] > 0) A[i] := A[i] * 2;

else A[i] = 10;

end;

end.

Ответить

Другие вопросы из категории

Задача номер 7. Пожалуйста решите. Заранее спасибо
Составить таблицу сложения и умножения для 6-ричной системы счисления. решить 767 в 8 * 123 в 8 = АВ1 в 16 * F4 в 16 = и

заполнить таблицу с решением..

в 2 ичной число 101010

в 8 ичной 777

в 10 ичной 999

в 16 ичной F0F

Определите для каждого из преведённых понятий, общее оно или единичное. Число Столица России Учебник Житель Москвы

Столица

Самая высокая гора

А.С. Пушкин

Сказочный персонаж

Баба Яга

Читайте также

Program gg;var a,b,c,x1,x2,D:real;beginwriteln (ââåäèòå êîýôôèöèåíòû a,b,c);read (2,5,25);D:b*b-4*a*cif D>0 then begin x1:=(-5-sgrt(D))/2*a; x2:=

(-5+sgrt(D))/2*a; wtiteln (x1;x2);end else if D=0 then begin x1:=(-b)/2*a writeln (x1);end else write (ðåøåíèé íåò) end.


это задача на Паскале,нужно скопируйте и вставте её)в 4 строке ошибка какая?

Задача на паскале Задан массив А размерности N случайным образом.

Нужно сформировать новый массив по следующему правилу:
все чётные элементы разделить на 2, все нечётные оставить без изменения

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

Найти алгоритм минимума из 3х целых чисел на паскале+ составить блок -схему.

ПОЖАЛУЙСТА,ХОТЯ БЫ НА ПАСКАЛЕ СОСТАВЬТЕ!



Вы находитесь на странице вопроса "Задача на Паскале(нужно полное решение)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.