Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дана матрица целых чисел размером 5х3. Определить максимальный и мини-мальный элемент матрицы. Результат вывести на экран монитора. только надо

10-11 класс

чтобы выводилась матрица для того чтобы было видно откуда берется мин и max

ImpertinentKid 31 окт. 2015 г., 8:08:40 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tanyaakchibash
31 окт. 2015 г., 9:56:21 (8 лет назад)

type mas=array[1..5,1..3] of integer;
var a:mas;
i,j,min,max:integer;

begin
randomize;
for i:=1 to 5 do
for j:=1 to 3 do
a[i,j]:=random(100)+1;
writeln('Исходная матрица');
for i:=1 to 5 do
begin
for j:=1 to 3 do
write(a[i,j]:4);
writeln;
end;
min:=a[1,1];
max:=a[1,1];
for i:=1 to 5 do
for j:=1 to 3 do
begin
if a[i,j]<min then min:=a[i,j];
if a[i,j]>max then max:=a[i,j];
end;
writeln('Минимальный элемент матрицы: ',min);
writeln('Максимальный элемент матрицы: ',max);
end.

+ 0 -
Galamad
31 окт. 2015 г., 11:08:27 (8 лет назад)

option explicit

dim s,k,i,j,max,min,a

privat sub cmdstart_click()

pic1.cls

redim a(1 to 5,1 to 3)

pic1.scale(0,0)-(5+1,3+1)

randomize:pic1.forecolor=vbblue

for i=1 to 5

for j=1 to 3

a(i,j)=int(rnd*100):pic1.currentx=j

pic1.currenty=i:pic1.print a(i,j)

next

next

max=a(1,1)

min=a(1,1)

for i=1 to 5

for j=1 to 3

if a(i,j)>max and a(i,j)<min then

end if

next

next

pic1.forecolor=vbred:pic1.print max, min

end sub

Ответить

Читайте также

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .



Вы находитесь на странице вопроса "Дана матрица целых чисел размером 5х3. Определить максимальный и мини-мальный элемент матрицы. Результат вывести на экран монитора. только надо", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.