Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Прошу о помощи!!!!! дана матрица целых чисел размером 4x3 определите максимальный элемент массива. нужно составить блок схему. помогите плиииз!

10-11 класс

Tamara678098 23 мая 2014 г., 20:09:22 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lyilyi
23 мая 2014 г., 22:08:43 (9 лет назад)

program picaso; uses crt;
type vector=array[1..100] of integer;
var a:vector;
    i,n,max:integer;
begin clrscr;
    writeln('n :');readln(n);
    for i:=1 to n do
    begin
        write('значение ',i,' : ');
        readln(a[i]);
    end;
    max:=a[1];
    for i:=1 to n do
        if a[i] > max then max:=a[i];
    
    writeln('максимальный элемент массива',max);
    
    readln;
end.

Ответить

Другие вопросы из категории

Дан массив , состоящий из n элементов, и числа a и b. Вычислить .

Y=П (от 1 до n) a( в степени xi)-b(в степени xi)

задан двухмерный массив надо

Найти сумму максимальных элементов столбцов матрицы Х(n, n).

вот написал но не так как надо делает помогите
Private Sub CommandButton4_Click()
ReDim w(m, n)
For j = 1 To n
Max = 0
For i = 1 To mIf Max < a(i, j) Then Max = a(i, j)
Next i
MaxNext j
TextBox2.Text = TextBox2.Text + Str(s) + " "
End Sub

для какого названия города истинно высказывание:

(первая буква гласная^последняя буква гласная)~название содержит букву "М")?
1)Москва
2)Дюссельдорф
3)Амстердам
4)Атланта

для кодирования букв а, б, в, г решили использовать двухразрядные последовательные двоичные числа (от 00 до 11 соответственно). Если таким способом

закодировать последовательность символов гбав и записать результат шестнадцатеричным кодом, что выйдет?

Читайте также

1. Помогите исправить ошибки и нарисовать блок-схему. Задание: дана матрица целых чисел размером

4х4. Поменять местами первый и последний элемент массива х.

Листингпрограммы:

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

на языке паскаль 1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел

среди 10 элементов вещественного массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов



Вы находитесь на странице вопроса "Прошу о помощи!!!!! дана матрица целых чисел размером 4x3 определите максимальный элемент массива. нужно составить блок схему. помогите плиииз!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.