Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

1. Помогите исправить ошибки и нарисовать блок-схему. Задание: дана матрица целых чисел размером

10-11 класс

4х4. Поменять местами первый и последний элемент массива х.

Листингпрограммы:

спасибозапомощь 19 авг. 2014 г., 12:03:12 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ксюша04072001
19 авг. 2014 г., 13:16:21 (9 лет назад)

Program matriza;
uses crt;
Const A: array [1..4, 1..4] of integer=((1,1,1,1), (2,2,2,2), (3,3,3,3), (4,4,4,4));
Var n, m, I, j: integer;
Begin
writeln ('исходящая матрица равна

Ответить

Другие вопросы из категории

Помогите решить школьную задачу на паскале

(Халявные баллы)

1. Определите

значение переменной S после выполнения операторов:

Исправьте ошибки пожалуйста Pascal!Линейные алгоритмы.Пара кроликов каждый год дает приплод двух (самку и самца) которые через 2 месяца способны давать

новый приплод. Сколько кроликов будет через год

program uses crt{Пара кроликов каждый год дает приплод двух (самку и самца)кот.через 2месяца способны давать новый приплод.Ск-ко кроликов будет через год.}

var k : integer

function f(n:integer):integer

begin if n=0

then f=1

elsey if n=1

then f=2

elsey f=f(n-2)+f(n-1)

end

begin for k=10 to 12 do

writeln(f(k))

redln

end.

Читайте также

Помогите исправить ошибки и написать блок-схему. Задание: Имеется массив А из N произвольных чисел, среди которых есть положительные,

отрицательные и равные нулю. Используя оператор цикла, составить программу, вычислить количество положительных и нулевых и сумму отрицательных.

Листинг программы:

Program Massiv;

Const n=10;

Var A:array [1..4] of integer;

I, c, c2, c3: integer;

Begin

For i=1 to N do begin

Readln (a[i]); If (a[i]=0 then inc(c)

Else if ([ai]<0) then inc(c2)

Else inc (c3);

End;

Writeln (`нулевые:`,c);

Writeln (`отрицательные:`,c2);

Writeln (`положительные:`,c3);

End.

Дан фрагмент программы. Нарисуйте блок-схему, восстановите вид формулы для расчета S

PASCAL:

VAR
A:ARRAY[1...100]OFF
INTEGER;
N,I,J: INTEGER;
S: REAL;
BTGIN
N:=8;
FOR I:=1 TO N DO
BEGIN
S:=0;
FOR J:=1 TO I DO
S:=S+(A[J]);
S:=ABS(S);
WRITELN(`S`=`,S:9:2);
END;
READLN;
END.

QBASIC
DEFINT N,I,J,S,
DIM A(100) AS INTEGER
N:=8
FOR I=1 TO N
S=0
FOR J=1 TO I
S=S+A[J]
NEXT J
S=ABS(S)
PRINT S
NEXT I

ШКОЛЬНЫЙ АЯ

алг слово(рез вещ s)
цел раб А[1:100]
n:=8
нц для I от 1 до n
s=0
нц для j от 1 до I
s=s+a[j]
кц
s=abs(s)
вывод s
кц
кон

Пожааалуйста нужны блок-схемы для трех вариантов получения s





1)Найти 3 совершенное число(программа+блок схемы)

2)Определить 35 простое число(программа +блок схемы)
3)Дано:трехзначное число ,определить :является ли произведение его цифр трехзначным числом(программа+блок схемы)

Помогите пожалуйста! 1)Построить развлетвляющийся алгоритм, записать алгоритмы ввиде блок-схемы и на алгоритмическом языке. Треугольник задан

длинами своих сторон – a, b, c. Определить является ли

он тупоугольным, прямоугольным или остроугольным.

2) Построить циклический алгоритм, записать ввиде блок-схемы и на алгоритмическом языке.

Построить алгоритм, который определяет количество студентов в группе,
чей рост превышает среднее для группы значение.



Вы находитесь на странице вопроса "1. Помогите исправить ошибки и нарисовать блок-схему. Задание: дана матрица целых чисел размером", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.