Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Нужно написать программу в Паскале срочно: С клавиатуры вводится число n. Заполнить массив с клавиатуры n значениями и вывести их произведение.

5-9 класс

марияСолнышко 19 апр. 2014 г., 15:10:55 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
настасія
19 апр. 2014 г., 16:52:41 (10 лет назад)

var
  a: array of byte; //Мы ведь не хотим выйти за пределы даже Int64?
  n, i: byte;          //Больше и не пригодится, массива из 255 значений хватит уж
  l: Int64 := 1;      //Произведение - большая цЫферка

begin
  readln(n);
  System.Array.Resize(a, n);
  for i := 0 to (n - 1) do
  begin
    write('a[', i, '] = ');
    readln(a[i]);
    l *= a[i];
  end;
  writeln(l);
end.

Ответить

Другие вопросы из категории

Помогите решить задачу на любом языке программирования.

Имеется ряд из N лампочек, которые пронумерованы от 1 до N. Изначально ни одна из лампочек не горит. Далее происходит K последовательных линейных инверсий этого ряда ламп. Под линейной инверсией понимается инверсия каждой P-й лампочки в ряде. Например, если P=3, то произойдет инверсия 3й, 6й, 9й и т.д. лампочек.Требуется определить: сколько горящих лампочек останется после реализации всех заданных линейных инверсий?

Входные данные:
В первой строке входного файла INPUT.TXT заданны числа N и K – число лампочек и число линейных инверсий. Вторая строка состоит из K целых чисел Pi, задающих период данных инверсий. (1 <= N <= 109, 1<=K<=100, 1 <= Pi <= 50)

Читайте также

Ребят) Помогите с программой на Паскале, пожалуйстаа)

Нужно написать программу, которая выводит на экран все двухзначные числа, делящиеся на 3 или на 5 (использовать операции целочисленного деления div или mod)

с клавиатуры вводится число х. если

с клавиатуры вводится число х. если остаток от деления х на 6 равен 2, то значение f(x)=4*x^2 если остаток от деления х на 6 равен 3, то значение f(x) = корень из х , если остаток от деления на 6 =0 то f(x) = x.


Написать программу в паскале используя операторы if и else . Нарисовать блок схему

Пожалуйста помогите создать какую нибудь полезную программу на паскаль , срочно нужно до понедельника, чтобы в этой программе были все темы за 8 класс,

read.writeln.else.to.if и тд которые сможете
Вот пример идеи для программы, в академию поступают какое то количество учеников, нужно написать сколько учеников сдали документы, сколько пришли на экзамен, и сколько учеников кто прошло и не прошло
возможно не возможно создать программу на этой идее, тогда прделагайте свои со своими программами , пожалуйста помогите!

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль

Прошу помогите написать программу в Паскале)

С клавиатуры ввели число. Если это число нечетное, то нужно найти сумму чисел в диапазоне от 1 до этого числа, иначе вывести сообщение о том, что число нечетное.



Вы находитесь на странице вопроса "Нужно написать программу в Паскале срочно: С клавиатуры вводится число n. Заполнить массив с клавиатуры n значениями и вывести их произведение.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.