Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать программу которая даст таблицу Q5*5. Каждый эелемент таблицы случайное число из отрезка [-30,+30]. Вычислить сумму все отрицательных и сумму

5-9 класс

положительных элементов.

030201040506 21 окт. 2014 г., 12:12:03 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sunnyalena2003
21 окт. 2014 г., 14:51:18 (9 лет назад)

var a,b,i,j,p,o: integer;
z:real;
m:array[0..31,0..31] of integer;
begin
randomize;
for i:=1 to 5 do
for j:=1 to 5 do
begin
z:=random;
b:=random(31);
if z<0.5 then m[i,j]:=b;
if z>0.5 then m[i,j]:=-b;
end;
for i:=1 to 5 do
for j:=1 to 5 do
begin
if m[i,j]>0 then p:=p+m[i,j];
if m[i,j]<0 then o:=o+m[i,j];
end;
write(p,' ',o);
end.

 

мда. подумать над задачкой пришлось немного) но вот результат)

Ответить

Читайте также

Помогите плиз срочно 1)Написать программу,которая спрашивает"Который час?" и,в зависимости от введенного времени,выводит приветствие:"Доброе

утро","Добрый день","Добрый вечер", "Спокойной ночи". 2)Написать программу,которая определяет,принадлежит ли точка с координатами (x,y)Заштрихованной области,ограниченной точками(x1,y1)(x2,y2).

Пожалуйста помогите решить желательно все или хотя бы одну (P.S. программа для программы Turbo Pascal) 1.Написать программу, которая предлагает

ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321)

3.Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.

помогите пожалуйста..очень надо....что нибудь из этих задач..1)написать программу которая поменяет местами первую и последнюю букву в слове. 2)написать

программу которая вставит между буквами веденного слова пробелы 3)написать программу вывода на экран деление двух чисел

5-9 класс информатика ответов нет
1. Написать программу, которая спрашивает «Который час?» и, в зависимости от введенного времени, выводит на экран приветствие: «Доброе утро», «Добрый

день», «Добрый вечер», «Спокойной ночи».
2. Составьте программу, которая вычисляет оптимальный вес пользователя, сравнивает его с реальным весом и выдает рекомендации о необходимости поправиться или похудеть. Оптимальный вес вычисляется по формуле: рост (в сантиметрах) – 100.
Помогите решить 2 задачи

составьте программу, которая вставляет слово ОБА после каждого слова, заканчивающегося на гласную.

Или

составьте программу, которая определяет на сколько в строке S слов, начинающихся на главную букву больше, чем в строке T

надо решить одну из них



Вы находитесь на странице вопроса "Написать программу которая даст таблицу Q5*5. Каждый эелемент таблицы случайное число из отрезка [-30,+30]. Вычислить сумму все отрицательных и сумму", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.