Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дан диапазон от 1 до 1000,вывести на экран все числа которые кратны 7 и одновременно 11.найти сумму этих чисел и количество,

5-9 класс

Dyrochka97 11 июля 2014 г., 2:02:38 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Daana98
11 июля 2014 г., 4:07:24 (9 лет назад)

var i, b, c: integer;

begin

b:=0;

c:=0;

for  i:=1 to 1000 do

begin

if (i mod 7=0) and (i mod 11=0) then 

begin

b:=b+1;

c:=c+i;

end;

end;

writeln('summ=',c,' kol=',b)

end.

Ответить

Читайте также

1 вывести на экран все трехзначные числа кратные 50

2 найти количество четных чисел начиная с числа 20 до 60
3 найти сумму нечетных чисел от 100 до 150
паскаль

Помогите пожалуйста, завтра контрольная, объясните турбо Паскаль (7 класс ) задачи будут примерно такие:

1)для чисел от а до 30,вывести на экран сами числа и их сумму с числом 123.
2)вывести на экран таблицу умножение на 4(1-10)

Дан массив из N элементов(12 элементов), заданный случайным образом от -10 до 10. Вывести на экран этот массив. С клавиатуры вводятся два числа меньше N.

Вывести на экран часть массива входящих в диапазон, двух введенных чисел. Эти два числа будут индексами к тем числам, которые надо вывести.

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

1)В диапазоне от 0 до 100 подсчитать количество чисел оканчивающихся на 3.

2)В диапазоне от 0 до 50 подсчитать количество чисел сумма цифр которых равна 3.



Вы находитесь на странице вопроса "Дан диапазон от 1 до 1000,вывести на экран все числа которые кратны 7 и одновременно 11.найти сумму этих чисел и количество,", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.