Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

написать задачу перевода из 10 с.с. в 2 с.с. двумя способами:

10-11 класс

1) функции
2) процедуры

EvoX 22 февр. 2014 г., 5:12:48 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Magafurova83
22 февр. 2014 г., 6:02:19 (10 лет назад)

function toBin(dec: integer): string;
var
  buf: integer;
  str: string;
begin
  buf := dec;
  repeat
    str := concat(IntToStr(buf mod 2), str);
    buf := buf div 2;
  until (buf = 0);
  toBin := str;
end;

procedure toBin(dec: integer; var bin: string);
var
  buf: integer;
begin
  buf := dec;
  repeat
    bin := concat(IntToStr(buf mod 2), bin);
    buf := buf div 2;
  until (buf = 0);
end;

var
  s: string;

begin
  writeln(toBin(10));
  toBin(10, s);
  writeln(s);
end.

Ответить

Другие вопросы из категории

1. Элементами рабочего стола являются:

1.значок программы
2.значок папки
3.панель задач
4.ярлык программы
5.значок документа
6.контекстное меню
7.кнопка пуск
8.диалоговое окно
Ответов несколько

Значение целочисленных переменных x,y и z после использование фрагмента программы:

X:=-3
Y:=4
If x*y< x-y then
Begin
Z:=x*x+y*y;
Y:=z-y;
X:=x*y+z;
End;
Else
Begin
Z:=x*2+y*3;
Y:=z-y*y;
X:=x*y+z;
End;

срочно помогите решить! дам много пунктов!!! пожалуйста, зачет по информатике!! в qBasiq Вариант №

1

Дан массив целых чисел, состоящий из 20 элементов. Заполнить его с клавиатуры.

1. Найти:

- сумму элементов, имеющих нечетное значение;

- вывести индексы тех элементов, значения которых больше заданного числа А.

2. Определить, есть ли в данном массиве положительные элементы, кратные k (k вводить с клавиатуры).

Читайте также

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.

А) Как переводить из двоич. в восьмирич и обратно (Также в 10-ную и 16-ную)

Б) Как переводить из букв (AF допустим) в двоичную систему?


Нужно перевести несколько чисел из одной системы счисления в другую: 1) число 161 из 10 с.с. в 2 с.с.; 2) число 3284 из 10 с.с. в 6 с.с.; 3) число 53996

из 10 с.с. в 16 с.с.; 4) число 11021021 из 3 с.с. в 10 с.с.; 5) число A369 из 16 с.с. в 8 с.с.

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

Ответить на следующие вопросы: 1)Информация, виды и формы информации 2)Алгоритмы, свойства алгоритмов 3)Системы счисления, перевод из одной системы

счисления в другую прошу очень кратко, и подробно расскажите о переводе из одной системы счисления в другую



Вы находитесь на странице вопроса "написать задачу перевода из 10 с.с. в 2 с.с. двумя способами:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.