Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Найти средне арифметическое элементов последовательности, превосходящих некоторое число С. Массив задан датчиком случайных чисел на интервале [-44,

10-11 класс

35]. Размер произвольный. Значение С вводится с экрана.

Zhenek2996 13 июля 2014 г., 8:34:26 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
MrProloloshka
13 июля 2014 г., 9:45:43 (9 лет назад)

var

a:array [1..20] of integer;

i,c,k:integer;

sr:real;

begin

randomize;

for i:=1 to 20 do begin

a[i]:=random(80)-44;

write (a[i],' ');

end;

writeln;

write ('C = ');readln(c);

for i:=1 to 20 do

if a[i]>c then begin

sr:=sr+a[i];

k:=k+1;

end;

sr:=sr/k;

writeln (sr:0:2);

readln;

end.

Ответить

Читайте также

Дан массив X(N).Найти среднее арифметическое элементов массива,значения которых заключены в интервале [-3;3]. Если эта величина больше

заданного числа Z,то найти сумму четных элементов,иначе- произведение нечетных элементов.

Друзья,очень нужна ваша помощь,пожалуйста,если Вы решили мне помочь-отпишитесь. Заранее спасибо!

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой

индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел



Вы находитесь на странице вопроса "Найти средне арифметическое элементов последовательности, превосходящих некоторое число С. Массив задан датчиком случайных чисел на интервале [-44,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.