Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1. Найти значение и номер первого отрицательного члена последовательности cos (сtg n)=1,2,3...

5-9 класс

Rita1509 07 апр. 2014 г., 10:57:46 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
хХхdocхХх
07 апр. 2014 г., 11:39:10 (10 лет назад)

var
x: real;

begin
  x := 1;
  while (cos(1 / tan(x)) >= 0) do x := x + 1;
  Write(x, ': ', cos(1 / tan(x)))
end.

Результат выполнения программы:

6: -0.956871790478342

Если нужна промежуточная печать:

var
x: real;

begin
  x := 1;
  while (cos(1 / tan(x)) >= 0) do begin
  Writeln(x, ': ', cos(1 / tan(x)));
  x := x + 1
  end;
   Writeln(x, ': ', cos(1 / tan(x)))
end.

Результат выполнения программы:

1: 0.800844301895226
2: 0.897089962539917
3: 0.743794228654611
4: 0.64963571596558
5: 0.956565479264333
6: -0.956871790478342




Ответить

Другие вопросы из категории

. Выберите правильный вариант

ответа. Обоснуй ответ.

В каком из представленных
устройств происходит обработка информации, перед её дальнейшим выводом?

а) оперативная память;

б) монитор;

в) процессор;

г) видеокарта.

Помогите составить ребус ,вопросами, а не картинками!

Плиз , зоранея спасибо!
слово передача

Читайте также

Помогите Решить 4 любые задачи:

1)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Сколько элементов последовательности превышает число 100?
2)Вводится последовательность из 10 вещественных чисел. Вычислить сумму элементов, не превышающих числа А.
3)С клавиатуры вводится последовательность из 7 целых чисел. Определить каких чисел больше: четных или нечетных.
4)С клавиатуры вводится последовательность из 9 чисел. Найти разность между макимальным и минимальным элементами.
5)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти порядковый номер отрицательного элемента, если считать элементы справа. В случае нескольких отрицательных элементов вывести номер последнего из них (т.е. самого правого).
6)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти порядковый номер первого двузначного элемента последовательности, считая элементы в прямом порядке.
7)С клавиатуры вводится последовательность положительных чисел, оканчивающаяся 0. Найти сумму двузначных элементов последовательности.
8)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти произведение отрицательных элементов последовательности.
9)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти в ней минимальный элемент.
10)С клавиатуры вводятся числа 2, 5 или 10, означающие удаления игроков на соответствующее кол-во минут. Условно положительные значения означают удаления в команде А, а отрицательные - в команде В. Для завершения ввода данных используется 0. Сколько всего штрафного времени заработано командами А и В отдельно, а также определить общее штрафное время.

Написать программу,которая вычисляет сумму первых n членов ряда 1,3,5,7. Количество суммируемых членов ряда задаётся во время роботы программы.

(ниже представлен рекомендуемый вид экрана во время работы программы)
Вычисление частичной суммы рада 1,3,5,7.
Введите количество суммируемых членов ряда: 15
Сумма первых 15 членов ряда равна 330.

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.



Вы находитесь на странице вопроса "1. Найти значение и номер первого отрицательного члена последовательности cos (сtg n)=1,2,3...", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.