Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Ввести число. Если число отрицательное, то умножить его на-1. Затем выдать на экран число и квадратный корень из числа.

10-11 класс

555ю26 18 апр. 2014 г., 8:39:46 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
павел990
18 апр. 2014 г., 9:17:57 (10 лет назад)

var a:integer;
begin
readln(a);
if a<0 then a*=-1;
write(a,' ',sqrt(a));
end.

Ответить

Другие вопросы из категории

Помогите решить задачу в Free Pascal. Необходимо написать текст и алгоритм (схему) программы. Буду очень-очень благодарнааа:**

Заданы массы некоторых двух тела m1, m2. Тела
движутся и проходят за время t

Какие функции выполняет прикладное ПО?

Выберите один или несколько ответов:
Антивирусная защита
Табличная обработка данных
Машинная и деловая графика
Работа с базами данных
Обработка текстовКакие функции выполняет прикладное ПО?

Все 5-буквенные слова, составленные из 5 букв А, К, Л, О, Ш,

записаны в алфавитном порядке.

Вот начало списка:

1. ААААА

2. ААААК

3. ААААЛ

4. ААААО

5. ААААШ

4. АААКА

……

Сколько всего 5-буквенных слов в этом списке?

Читайте также

ввести число.если оно положительное,уменьшить его на 3,пока оно не станет отрицательным.Если же число отрицательное,то увеличивать его на 2,пока оно не

станет больше 70.Ни экраны вевести оба число.

ЗАПИСАТЬ ЗАДАЧУ В ПАСКАЛЕ!И ЕСЛИ МОЖНО ПРАВИЛЬНУЮ БЛОК СХЕМУ!

Pascal

1)Задан список из 7 фамилий. Определить, имеется ли в списке фамилия, начинающаяся с буквы "А" и состоящая из 6 букв. Если да, то вывести ее на экран
2)В заданном тексте удалить символ ' , ' и подсчитать число удаленных символов. Предусмотреть возможность задания с клавиатуры удаляемого символа.
3)Организовать простейшую базу данных по студентам группы. Сведения о студенте включают: ФИО, год рождения, пол, средний балл. Обеспечить ввод данных, редактирование, вывод на экран. Информацию хранить в типизированном файле.
Помогите пожалуйста решить. отдаю полностью все свои баллы

составьте блок-схему и программу для решения следующей задачи. Введите с клавиатуры два числа: к и л. Если они положительны, то замените каждое на квадрат

их суммы и выведите результаты на экран. Если все числа отрицательны, то каждое сделайте равным наименьшему и выведите результаты. Иначе, К приравняйте к 10, а Л - к 15 и выведите результаты

Задан одномерный массив А(N) (N<=60). На место минимального элемента массива записать сумму последних К элементов массива. Если А[1]>=0, то умножить

все элементы этого массива на квадрат минимального элемента данного вектора, а если А[1]<0, то умножить все элементы на квадрат максимального элемента вектора. Полученный массив распечатать. Значение К вводится пользователем.

Помогите пожалуйста!

1) Дано целое число. Если оно четное, то прибавь к нему 28, если отрицательное - вычти из него 12, если равно 0, то замени на -100. Вывести полученное число.

2) Ввести два числа. Если их произведение отрицательно, умножить его на -2 и вывести на экран, в противном случае увеличить его в 1,5 раза и вывести на экран.

Не понимаю программирование... :(





Вы находитесь на странице вопроса "Ввести число. Если число отрицательное, то умножить его на-1. Затем выдать на экран число и квадратный корень из числа.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.