Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дан линейный массив А[1..N], содержащий целые числа.Посчитать сумму чисел,имеющих одинаковые остатки при делении на 7 и на 2 и распечатать номера

5-9 класс

таких чисел "

кролик123 07 февр. 2014 г., 1:43:30 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
2837579953
07 февр. 2014 г., 3:40:54 (10 лет назад)

2 задача

var 
m:array[1..100] of integer;
i,n:integer;
begin
readln(n); // число ячеек 1<=n<=100
for i:=1 to n do
readln(m[i]); // вводим сам массив
for i:=1 to n do
begin
if m[i] mod 2 = 0 then m[i]:=m[i] div 2;
if m[i] mod 2 = 1 then m[i]:=m[i] mod 3;
end;
for i:=1 to n do
writeln(m[i])

end.


+ 0 -
Dima270605
07 февр. 2014 г., 5:13:54 (10 лет назад)

6 ячеек

+ 0 -
Mineks
07 февр. 2014 г., 8:08:37 (10 лет назад)

программа не трудная, но долгая (потому что мы не знаем какой должен быть остаток, придётся составлять второй массив) решать за 8 балов не хочется(хотя бы за 25 ).Если было бы известен остаток, то программу составлю за 2 минуты

+ 0 -
Nadi1985
07 февр. 2014 г., 10:38:37 (10 лет назад)

а вторую задачу можешь решить ? Дан линейный массив А[1..N], содержащий целые числа.Преобразовать элементы массива по следующему правилу :если элемент четный , то разделить его на 2 , если нечетный -заменить его остаток от деления на 3

+ 0 -
Thenitra
07 февр. 2014 г., 11:20:10 (10 лет назад)

да сейчас пришлю решение

+ 0 -
Sadovskaya10
07 февр. 2014 г., 12:35:21 (10 лет назад)

Спасибо тебе огромное :) ты меня спас

Ответить

Другие вопросы из категории

РЕБЯТА ПОМОГИТЕ ПОЖАЛУЙСТА ПОМОГИТЕ ПОЖАЛУЙСТА!!НУЖНО РЕШЕНИЕ ЗАДАЧИ,ОТ РЕШЕНИЯ ЭТОЙ ЗАДАЧИ,ЗАВИСИТ МОЯ ОЦЕНКА. БУДУ ОЧЕНЬ БЛАГОДАРНА

Создать целочисленный массив из 15 чисел. Заполнить с помощью генератора случайных чисел с элементами от -15 до 30. И вывести его на экран. Определить самый большой элемент массива и его индекс.
A (i):=random (x) -15
от -1 до х
от -15 до 30.

1)среди 15 чисел найдите сумму всех положительных чисел

2) среди 15 чисел найдите количество всех чисел которые являются не отрицательными

Срооочно!!!

нужно составить программу на Паскале
на квадратное уравнение!

Составьте программу, позволяющую вставить слово t после первого слова исходной строки s. Строка s и слово t вводятся с клавиатуры. (PascalABC)

Пример ввода:
Наступила осень
золотая
Пример выводы:
Наступила золотая осень.

Читайте также

1. Указать ошибки в описании массива и пути их исправления: var a:array[real] of integer;

2. Определить,что распечатает следующая программа:
var a: array[1..5,1..5]of integer,i,j; integer;
begin
for i:=1 to 5 do begin
for j:=1 to 5 do begin
if i=5-j+1 then a[i,j]:=0
else a [i,j]:=0;
write(a[i,j]:2);
end;
writeln;
end; end.
3. Дан линейный массив a [l..n], содержащий целые числа. Вычислить сумму чисел делящихся одновременно на 5 и на 3 и распечатать номера таких чисел
4.Дан линейный массив a [l..n], содержащий целые числа. Преобразовать элементы массива по следующему правилу : если элемент положительный,то заменить его на 1, а если отрицательный - возвести в квадрат

PascalABC 40 баллов!!!

1) Дан линейный массив a[1..n], содержащий целые числа. Вычислите сумму нечетных чисел и распечатать номера таких чисел. 2) Дан линейных массив [1..n], содержащий целые числа. Преобразовать элементы массива по следующему правилу: если элемент положительный, то умножить его на два, а если отрицательный -- поменять знак на противоположный.

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.



Вы находитесь на странице вопроса "Дан линейный массив А[1..N], содержащий целые числа.Посчитать сумму чисел,имеющих одинаковые остатки при делении на 7 и на 2 и распечатать номера", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.