Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

дано 30 натуральных чисел. вычислить среднее арифметическое всех нечетных чисел(Паскаль)

5-9 класс

Vi160201 01 янв. 2014 г., 3:31:53 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
BAGSS83
01 янв. 2014 г., 5:55:39 (10 лет назад)

program pas;
var
a:array[1..30] of integer;
i, k: integer;
s: real;
begin
s:=0;
k:=0;
  for i:=1 to 30 do
        readln(a[i]);
       
          for i:=1 to 30 do
            begin
              if (not(a[i]mod 2=0)) then
              s:=s+a[i];
              inc(k);
            end; 
            s:=s/k;
            write(s:4:0);
end.

Ответить

Другие вопросы из категории

Найдите первую цифру числа. Например, для числа 7658 это цифра 7. Написать блок-схему и программу.

Pascal ABC
Напишите пожалуйста полную программу.
Заранее спасибо)

Студенты педагогического института организовали эстрадный квартет.Михаил играет на саксофоне.Пианист учится на географическом факультете.Ударника зовут не

Валерием ,а студента географического факультета зовут не Леонидом.Михаил учится не на историческом факультете.Андрей не пианист и не биолог.Валерий учится не на физическом факультете,а ударник-не на историческом.Леонид играет не на контрабасе.На каком инструменте играет Валерий и на каком факультете он учится?

Читайте также

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

Проблема с Паскалем. Мне надо посчитать среднее арифметическое всех отрицательных чисел в массиве из десяти элементов. Я понимаю, как сначала надо

распредилить, какие числа меньше нуля, но как вычислить среднее арифметическое, не зная точное кол-во отрицательных элементов? Желательно написать полной программой. Заранее спасибо с:

1)Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 4. Программа получает

на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

2)Найти среднее арифметическое всех целых чисел от a до 200 (значения a и b вводятся с клавиатуры; a>=200);

Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 9, или вывести NO, если таких чисел в последовательности нет.

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!



Вы находитесь на странице вопроса "дано 30 натуральных чисел. вычислить среднее арифметическое всех нечетных чисел(Паскаль)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.