Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

помогите пожалуйста составить программу в Паскале, чисто 2 задание,в заранее спасибо)))

10-11 класс

Anastasiya0319 13 июля 2014 г., 2:44:47 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kotelnikov1
13 июля 2014 г., 4:54:21 (9 лет назад)

var c1, c2, c3: integer;
    b: boolean;
begin
     readln(c1, c2, c3);
     if (c1 = c2 * c3) then
     begin
          b := true;
          writeln(c1, ' = ', c2, ' * ', c3);
     end;
     if (c3 = c1 * c2) then
     begin
          b := true;
           writeln(c3, ' = ', c1, ' * ', c2);
     end;
     if (c2 = c1 * c3) then
     begin
          b := true;
           writeln(c2, ' = ', c1, ' * ', c3);
     end;
     if not (b) then writeln('NO');
end.

Третье ради спортивного интереса сделал:)
var a, b: string;
begin
     writeln('Enter a string: ');
     readln(a);
     readln(b);
     if (Pos(b, a) = 0) then writeln('No') else writeln('Yes');
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста ))СоставитьПомогите пожалуйста ))Составить программу по которой проверяют является ли элемент массива четным числом.Для записи

"делятся на"использовать стандартную функцию MOD,которая определяет остаток отделение числа А на число В.Примечание таблица R целочисленная.Построение блок-схемы,алгоритм и бейсики.Заранее большое спасибо))

Помогите пожалуйста)

Если можно то письменно)
заранее спасибо)

Читайте также

Здравствуйте, уважаемые :) Помогите пожалуйста составить программу на Паскале. Спасибо огромное!

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду щего элемента;
3-й-равен сумме двух предыдущих элементов.

Помогите пожалуйста написать программу в паскале.

Составить программу перевода натурального числа из десятичной системы счисления в двоичную

10-11 класс информатика ответов нет


Вы находитесь на странице вопроса "помогите пожалуйста составить программу в Паскале, чисто 2 задание,в заранее спасибо)))", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.