Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Pascal

5-9 класс

Выведите все числа на отрезке от a до b, являющиеся полными квадратами.

любстик 31 июля 2014 г., 4:12:04 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
анаствик
31 июля 2014 г., 5:12:30 (9 лет назад)

Var a,b,i:integer;
      x:real;
Begin
Readln(a);
Readln(b);
If a<0 Then a:=1;
For i:=a to b do
 Begin
  x:=sqrt(i);
  If frac(x)=0 Then Write(i,' ');
 End;
End.

Ответить

Другие вопросы из категории

примеры информационных процессов в живой природе (по информацией)

Получение-
Хранение-
Передача-
Обработка-
Кадирование-

ребус решите срочно!

М----→О

что выводит на экран следующая программа?program: TA6

type: culoare = (galben,verde,albastru,violet)
begin:
writeln(pred ("z"))
writeln (succ("d"))
writeln(pred (-5))
writeln(ord (verde))
writeln (ord(violet))
end

Как нарисовать это в черепашке с использованием цикла?

Вот мои наброски...
Программа { покажись; опусти_перо;

вперед ( 40 );
вправо ( 90 );
вперед ( 40 );
вправо ( 90 ) ;
вперед ( 40 );
влево ( 60 );
вперед ( 40 );
влево ( 60 );
вперед ( 40 );
вправо ( 90 ) ;
вперед ( 40 ) ;
вправо ( 90 );
вперед ( 40) ;
влево ( 60 ) ;
вперед ( 40);



}


Читайте также

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc

2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC



Вы находитесь на странице вопроса "Pascal", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.