Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Даны 3 числа,написать программу подсчитывающую количество отрицательных чисел и сумму неотрицательных чисел

5-9 класс

Valerusiap 20 дек. 2014 г., 3:01:20 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
JenyaPlu
20 дек. 2014 г., 5:02:48 (9 лет назад)

Program p2;
Var a,b,c:integer;
kolichestvo:byte;
summa:integer;
Begin
kolichestvo:=0;
summa:=0;
Readln(a);
If a<0 then
kolichestvo:=kolichestvo+1 else
summa:=summa+a;
Readln(b);
If b<0 then
kolichestvo:=kolichestvo+1 else
summa:=summa+b;
Readln(c);
If c<0 then
kolichestvo:=kolichestvo+1 else
summa:=summa+c;
Writeln('Количество отрицательных = ',kolichestvo);
Writeln('Сумма положительных = ',summa);
End.

Ответить

Читайте также

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего – в куб и нахождения среднего

арифметического полученных значений.
2. За весну Обломов похудел на p1 кг, за лето поправился на p2 кг, за осень похудел на p3 кг, за зиму поправился на p4 кг. Написать программу, определяющую, похудел или поправился за год Обломов.
3. Написать программу, которая определяет, является ли целое число четным двузначным числом.
4. Даны коэффициенты квадратного уравнения. Написать программу, определяющую его корни

1.Дано целое число составить программу которая определяет оканчивающие данное число цифрой семь.

2.Дано 2х значное число составить программу с помощью которой можно отпределить входит ли в это число цифра шесть.

Помогите написать программу для Паскаля.

1. Написать программу нахождения произведения n чисел.



Вы находитесь на странице вопроса "Даны 3 числа,написать программу подсчитывающую количество отрицательных чисел и сумму неотрицательных чисел", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.