Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

найти произведение всех двухзначных нечетных натуральных чисел с помощью ABC Паскаль

10-11 класс

Pavelkrav1 21 июля 2016 г., 2:57:05 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Julia465
21 июля 2016 г., 3:31:47 (7 лет назад)

var
  i: integer;
  p: double;

begin
  i := 11; p := 1;
  while(i <= 99) do
  begin p := p * i; i := i + 2 end;
  Writeln('Произведение всех двухзначных натуральных нечетных чисел: ', p)
end.

Результаты решения:
Произведение всех двухзначных натуральных нечетных чисел: 2.88401284629707E+75

Точный ответ: 2884012846297068257122447878731130828879149556133125305538972299939794921875







+ 0 -
Omarmeladze333
21 июля 2016 г., 6:18:46 (7 лет назад)

var
  i, p: longint;
begin
  p := 1;
  for i:=10 to 99 do
  if (i mod 2)<>0 then  p := p * i;
  Writeln('Произведение всех двухзначных натуральных нечетных чисел: ', p)
end.

Ответить

Другие вопросы из категории

Читайте также

. Даны два целых числа A и B

(A < B). Найти произведение всех целых чисел от A до B
включительно.

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.

Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В , сумма цифр которых четна. Программа

получает на вход два натуральных числа А и В, не превосходящих 10^9^ А<=В . Программа должна вывести одно число - кол-во натуральных чисел, больше или равных А и меньших или равных В, сумма цифр которых четна.



Вы находитесь на странице вопроса "найти произведение всех двухзначных нечетных натуральных чисел с помощью ABC Паскаль", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.