Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Задача. Линейный массив (вектор) T, размерностью 31 элемент заполнен целыми случайными числами, сгенерированными в интервале [-10;

10-11 класс

10]. Необходимо:

определить максимальный по модулю элемент массива; вывести номер (любого, если их несколько) и значение такого элемента; определить, сколько в предложенном массиве таких элементов и вывести их номера.

Timoha2003A 28 мая 2013 г., 6:23:28 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
111972271977
28 мая 2013 г., 8:39:33 (10 лет назад)

////////////////////////////////////////

Ответить

Другие вопросы из категории

вводится число от 1 до 1000

вывести на экран надпись не цифрами а выражением
555- пятьсот пятьдесят пять выдает
используйте массив

Во сколько раз уменьшится информационный объем страницы текста (текст не содержит управляющих символов форматирования) при его преобразовании из кодировки

Unicode (таблица кодировки содержит 65 536 символов) в кодировку ASCII (таблица кодировки содержит 256 символов)?
a. в 16 раз
b. в 8 раз
c. в 1,5 раза
d. в 2 раза

Читайте также

На Паскале решить задачу. Задан целочисленный вектор Х размерностью n, представляющий последовательность целых чисел. Определить число инверсий

в этой последовательности.

рекомендации: инверсией считать пару элементов, в которой большее число находится перед меньшим (хi>xj, если i>j)

Помогите с Pascal, пожалуйста. Завтра нужно домашку сдать, а я ничего не понимаю :(

Решите хотя бы одну, или две)
Вот задачи:
1. Заполнить одномерный массив, размерностью 15 по следующему правилу: на нечетном месте должен стоять элемент от 10 до 100, а на четном месте должен находиться нечетный элемент на том же промежутке.
2. Дан одномерный массив, заполненный целыми случайными числами. Определить, на сколько больше сумма четных элементов по сравнению с суммой элементов кратных 3.
3. Дан двумерный массив, размерностью 6х7. Определить, сумма каких элементов больше: 2-го столбца или 3-ей строки.

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

помогите исправить ошибки.Масиви. Уплотнить линейный массив, удалив нули и сдвинув влево остальные элементы program

{ Уплотнить линейный массив удалив нули и сдвинув влево остальные элм.}

uses crt

var m,i,k:longint a:array[1..100]of longint

begin

clrscr

write('введите кол-во элм таблицы: ')redln(k)

for i=1 to k do

begin

write('a[',i,']=')redln(a[i])

end

m=0

for i=1 to k do

if a[i]=0 then inc(m)

elsey a[i-m]=a[i]k=k-m

for i=1 to k do write(a[i],' ')redln

end.



Вы находитесь на странице вопроса "Задача. Линейный массив (вектор) T, размерностью 31 элемент заполнен целыми случайными числами, сгенерированными в интервале [-10;", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.