Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Массив М (20) заполнить целыми случайными числами от 0 до 10. Вывести его на экран. Подсчитать количество элементов, равных минимальному.

10-11 класс

Vlad91 21 авг. 2014 г., 23:34:19 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
настя19990518
22 авг. 2014 г., 1:51:55 (9 лет назад)

var m:array[1..20] of integer;
a,b,min:integer;
begin
b:=0;
for a:=1 to 20 do
begin
m[a]:=random(11);
writeln('m[',a,']=',m[a]);
end;
min:=10;
for a:=1 to 20 do 
begin
if m[a]<min then min:=m[a];
end;
for a:=1 to 20 do begin
if m[a]=min then b:=b+1;
end;
writeln('Количество минимальных элементов равно ',b);
end.

Ответить

Другие вопросы из категории

1. Помогите исправить ошибки и нарисовать блок-схему. Задание: дана матрица целых чисел размером

4х4. Поменять местами первый и последний элемент массива х.

Листингпрограммы:

Помогите решить школьную задачу на паскале

(Халявные баллы)

1. Определите

значение переменной S после выполнения операторов:

Исправьте ошибки пожалуйста Pascal!Линейные алгоритмы.Пара кроликов каждый год дает приплод двух (самку и самца) которые через 2 месяца способны давать

новый приплод. Сколько кроликов будет через год

program uses crt{Пара кроликов каждый год дает приплод двух (самку и самца)кот.через 2месяца способны давать новый приплод.Ск-ко кроликов будет через год.}

var k : integer

function f(n:integer):integer

begin if n=0

then f=1

elsey if n=1

then f=2

elsey f=f(n-2)+f(n-1)

end

begin for k=10 to 12 do

writeln(f(k))

redln

end.

Читайте также

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

1.Одномерный массив заполнен случайным образом. Найти количество четных элементов. 2. Одномерный массив размерностью N , где N -нечетное число,

заполнен случайными числами от -15 до 6. Все , числа кратные 3 заменить на противоположные.

Для кодирования номеров автомобилей принята следующая структура данных: Номер региона (двузначное число от 00 до 99), серия (комбинация из трех букв из

набора «А, В, Е, К, М, Н, О, Р, С, Т, У, Х»), номер (трехзначное число от 000 до 999). При создании базы данных автомобильных номеров Петя решил хранить каждый номер в виде массива из 8 символов (два символа на номер региона, три символа на серию и три символа на номер), кодируя каждый символ с помощью однобайтной кодировки ASCII. Вася решил уменьшить объем хранимых данных и принял решение хранить каждый номер в виде трех чисел – одно число для номера региона, одно число для серии (представив все возможные серии в виде натуральных чисел) и одно число для номера. Каждое число Вася будет хранить отдельно, используя для его кодирования минимально возможное число бит. На сколько бит уменьшится объем памяти, необходимый для хранения одного произвольного номера, в варианте кодирования Васи по сравнению с вариантом кодирования Пети? В ответе укажите целое число.



Вы находитесь на странице вопроса "Массив М (20) заполнить целыми случайными числами от 0 до 10. Вывести его на экран. Подсчитать количество элементов, равных минимальному.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.