Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

задана квадратичная матрица А порядка N состоящая из действительных элементов.Найти сумму элементов строки,в которой расположен наибольший элемент.

10-11 класс

тренихина 15 мая 2015 г., 0:41:43 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Лера7766
15 мая 2015 г., 3:41:38 (9 лет назад)

var a:array [1..100,1..100] of real;
i,j,maxi,n:integer;
s,max:real;
Begin
    read(n);
    for i := 1 to n do
        for j := 1 to n do begin
            read(a[i,j]);
            if ((i=1) and (j=1)) or (max<a[i,j]) then begin
                max:=a[i,j];
                maxi:=i;
            end;
        end;

    for j := 1 to n do
        s:=s+a[maxi,j];

    writeln(s);
End.

+ 0 -
Катушка02
15 мая 2015 г., 4:24:49 (9 лет назад)

#include <iostream>

using namespace std;

int main()
{
int N;
cin >> N;
float** A;
A = (float**) malloc(N * sizeof(float*));
for(int i = 0; i < N; i++)
A[i] = (float*)malloc(N * sizeof(float));
for(int i = 0; i < N; i++)
for(int j = 0; j < N; j++)
cin >> A[i][j];
int I1;
int max = A[0][0];
for(int i = 0; i < N; i++)
{
for(int j = 0; j < N; j++)
{
if(A[i][j]>max)
{
max = A[i][j];
I1 = i;
}
}
}
int sum = 0;
for(int i = 0;i<N;i++)
sum+=A[I1][i];
cout<<sum<<endl;
system("PAUSE");
return 0;
}

Ответить

Другие вопросы из категории

Если в сети с кольцевой структурой на одном из участков поврежден кабель, то ...

1) ...вся сеть в целом становится неработоспособной

2) ...нарушается связь только между ближайшими к повреждению компьютерами

3) ...нарушается связь только с одной из рабочих станций, все остальные сохраняют
работоспособность

4) ...сеть делится на две работоспособных части, однако связь между ними отсутствует

Помогите пожалуйста, программирование С++ в VisualStudio

тема "вложенные циклы"
как сделать вот таких пингвинчиков, может кто в курсе каким образом?._.

Читайте также

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.

Составить функцию определения факта нахождения в одномерной матрице хоть одного нуля, состоящей из целых чисел и количеством элементов k. применить данную

функцию для нахождения номеров строк, произвольной матрицы, не содержащей нулей. Составить на языке паскаль.

Вывести все правильные скобочные выражения длиной N, состоящие из круглых и квадратных скобок.

Ввод
В первой строке находится единственное число N.
Вывод
Каждое выражение выводится в отдельной строке.
Ограничения
1 ≤ N ≤ 14, N - четное.
Вывести все правильные скобочные выражения длиной N, состоящие из круглых и квадратных скобок.
Ввод
В первой строке находится единственное число N.
Вывод
Каждое выражение выводится в отдельной строке.
Ограничения
1 ≤ N ≤ 14, N - четное.

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.



Вы находитесь на странице вопроса "задана квадратичная матрица А порядка N состоящая из действительных элементов.Найти сумму элементов строки,в которой расположен наибольший элемент.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.