Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

дан массив натуральных чисел найти количество элементов кратных данному k СРОЧНО! ПОЖАЛУЙСТА ПОМОГИТЕ!

10-11 класс

Ikola 28 мая 2015 г., 23:59:44 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Afsanamamedova
29 мая 2015 г., 0:35:24 (8 лет назад)

Быол бы неплохо указывать среду прoграммирования.
Paskal.

program massiv;
uses crt;
var A:array [1..200] of integer; n, i, k, s: integer;
begin;
clrscr;
writeln ('введите количество элементов в массиве');
readln(n);
randomize;
writeln ('задан массив');
for i:=1 to n do
begin
a[i]:=-10+random(21);
write (a[i], ' ');
end;
writeln;
writeln ('введите число'); {кратное которому необходимо найти}
readln (k);
for i:=1 to n do

if (a[]i]<>0) and (a[i] mod k = 0) then s:=s+1;

write ('количество элементов кратных введенному числу - ', s);

readkey
end. 

Ответить

Другие вопросы из категории

Если в сети с кольцевой структурой на одном из участков поврежден кабель, то ...

1) ...вся сеть в целом становится неработоспособной

2) ...нарушается связь только между ближайшими к повреждению компьютерами

3) ...нарушается связь только с одной из рабочих станций, все остальные сохраняют
работоспособность

4) ...сеть делится на две работоспособных части, однако связь между ними отсутствует

Читайте также

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

Дан массив целых чисел из 15 элементов, заполненный случайным образом числами из промежутка [ -20, 50 ].

Удалить из него все элементы, в записи которых есть цифра 5.
Вставить число k после всех элементов, кратных своему номеру (k вводится с клавиатуры).
Поменять местами первый положительный и последний отрицательный элементы.

на языке паскаль 1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел

среди 10 элементов вещественного массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел среди 10 элементов вещественного

массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов



Вы находитесь на странице вопроса "дан массив натуральных чисел найти количество элементов кратных данному k СРОЧНО! ПОЖАЛУЙСТА ПОМОГИТЕ!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.