Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

3. Дана последовательность, вычислить сумму всех двузначных чисел последовательности

10-11 класс

Perst04 23 окт. 2013 г., 15:22:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Аня19082003
23 окт. 2013 г., 17:26:07 (10 лет назад)

if(a[i] div 100 = 0) and (a[i] div 10 <> 0) then s:= s+a[i];

Ответить

Другие вопросы из категории

Автомат получает на вход два двузначных шестнадцатеричных числа . В этих числах все цифры не превосходят цифру 6 (если в числе есть цифра больше 6,

автомат отказывается работать). По этим числам строится новое шестнадцатеричное число по следующим правилам. 1) Вычисляются два шестнадцатеричных числа – сумма старших разрядов заданных чисел и сумма младших разрядов этих чисел . 2) Полученные два шестнадцатеричных числа записываются друг за другом в порядке возрастания (без разделителей). Пример. Исходные числа: 66, 43. Поразрядные суммы: A, 9. Результат: 9A. Определите, какое из предложенных чисел может быть результатом работы автомата : 1) AF 2) 410 3) 8B 4) 76 (и объясните, пожалуйста, как это решать вообще)) )

Помогите пожалуйста на компьютере посчитать(((у меня просто он сдох

На обычном
На инженерном
Паскаль не надо

Читайте также

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.

Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих

256. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.

дана программа нахождения суммы всех элементов массива. Изменить программу таким образом,чтобы:

a) массив состоял из 15 элементов вещественного типа;
b) значения элементов массива должны меняться в интервале от 0 до 5;
c) в результате выполнения программы должно быть найдено произведение всех элементов массива, а не их сумма

Program massiv;
const n=10;
Var a: array [1..n] of integer;
s,i integer;
Begin
writeln (‘ исходный массив.‘);
For i:= 1 to n do
begin
a [ i] := random (10);
write (‘a[‘i'] =', a[i], '');
end;
s:=0;
For i:= 1 to n do
s:= s+a[i];
Writeln (‘ сумма всех элементов массива S=‘, s);
end.

1)Написать программу вывода всех четных чисел от 2 до 1000 включительно

2)Написать программу определяющую сумму всех нечетных чисел от 1 до 99



Вы находитесь на странице вопроса "3. Дана последовательность, вычислить сумму всех двузначных чисел последовательности", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.