Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Определите средний балл всех решить на С#Определите средний балл всех учащихся по каждому предмету.

5-9 класс

Формат входных данных Заданы сначала количество учащихся n, затем n строк, каждая из которых содержит фамилию, имя и три числа (оценки по трем предметам: математике, физике, информатике). Данные в строке разделены одним пробелом. Оценки принимают значение от 1 до 5.
Формат выходных данных Выведите три действительных числа: средний балл всех учащихся по математике, по физике, по информатике.Пример
Ввод Вывод
4 4.75 3.75 4.5
Ivanov Vasiliy 5 3 4
Petrov Sergey 4 3 5
Konstantinov Nikolay 5 5 5
Kuznetsov Ivan 5 4 4

Anyuta1000 31 марта 2014 г., 6:48:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kelolom
31 марта 2014 г., 7:58:05 (10 лет назад)

int n;
public struct shkolyari{
int a1,a2,a3;
String name;
}obj[n];
Console.Readln(n);
for(int i =0 ; i<n; i++)
{
Console.Readln(obj[i].name + a1+a2+a3);
}
for(int i =0 ; i<n ; i++)
{
int sum1 = sum1+obj[i].a1;
int sum2 = sum2+obj[i].a2;
int sum3 = sum3+obj[i].a3;
}
Console.WriteLine(\ sum1 + sum2 + sum3 )

Ответить

Другие вопросы из категории

Помогите , пожалуйста . Нужно написать программу для Паскаль.

Ввести пять чисел и найти наибольшее из них.
Я тут написал кое-что ,но не знаю правильно ли :(
HELP ME.

program ru;
var a,b,c,d,e,max:integer;
begin
writln('Введите пять целых чисел');
if a>b then
begin
max:=a;
end
else begin
max:=b;
end;
if max>c then
begin
max:=max;
else begin
max:=c;
end;
if d>e then begin
max:=d;
end
else begin
max:=e;
end.

Информатика-это скажите
подготовьте рассказ об устройствах для работы с данными , о которых не сказано в этом пункте ( есть : мобильный телефон , диктофон , факс ..

калькулятор , игровые приставки , фотокамера кинокамера , GPS - навигаторы

Читайте также

Составить программу которая определяет средний балл учащихся группы.

Программа должна спрашивать:
₋ сколько в группе человек,
₋ какой средний балл у каждого учащегося.
Пожалуйста составьте правильно, очень надо, заранее спасибо.

написать прогу на паскале: у фигуристов проходит конкурс. Им присуждют баллы за 1-ю,2-ю и 3-ю программу катания. Найти средний балл всех трех программ

для каждого фигуриста, сумму балов для каждого фигуриста. Массив заполняется рандомом (желательно небольшие числа), кол-во фигуристов вводится с клавиатуры + найти победителя (максимальный средний балл)

Помогите, пожалуйста, решить задачи на языке программирования в Turbo Pascal. 1) Определить максимальн

ый элемент квадратной матрицы, расположенный в правой части, ограниченной диагоналями, включая диагональные элементы.

2) Дана таблица с оценками 12 учащихся по девяти предметам. Определить номер предмета, содержащий максимальный средний балл.

1)Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 4. Программа получает

на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

2)Найти среднее арифметическое всех целых чисел от a до 200 (значения a и b вводятся с клавиатуры; a>=200);



Вы находитесь на странице вопроса "Определите средний балл всех решить на С#Определите средний балл всех учащихся по каждому предмету.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.