Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Составьте

10-11 класс

программу, определяющую принадлежность точки А(х, у) окружности с центром
0(0; 0) и радиусом R.

В паскалеABC.

Уральская 26 мая 2014 г., 17:17:09 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alinaaaaaaalin
26 мая 2014 г., 19:30:50 (9 лет назад)

var x,y,r:real;
begin
writeln('Введите радиус окружности');
readln(r);
writeln('Введите координаты точки А');
readln(x,y);
if sqr(x)+sqr(y)=sqr(r) then writeln('Принадлежит')
else writeln('Не принадлежит');
end.

+ 0 -
Vikasafonva
26 мая 2014 г., 20:13:39 (9 лет назад)

var x,y,r:real;
begin
readln(r);
readln(x,y);
    if sqr(x)+sqr(y)<=sqr(r) then
        writeln('принадлежит')else writeln('не принадлежит');
end.
в предыдущем решении точка лежит только на границе окружности

Ответить

Другие вопросы из категории

В ОС WINDOWS NT информация о паролях пользователей хранится:

(укажите несколько вариантов ответа)


1) В файле user.dat

2) В файле sam.sav

3) В файле sam

4) В файле system.dat

5) В файлах с расширением pwl

запишите заголовки цикла for для изменения параметра из диапазонов от -10 до +10______________________ от 100 до 1

_______________________

от 15 до 25 ________________________

от -10 до -20 ___________________________

Читайте также

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.

1)составить программу, организующую массив записей о книгах, ввести информацию по следующим полям:автор, название, год издания. Провести сортировку и

вывести список книг, изданных после 2003 года.



2)составить программу , организующую массив записей о пяти студентах и их оценках по трем предметам. провести сортировку и вывести список отличников.

помогите составить программу!пожалуйста!!!!ооочень надо

ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V.
Известно,что при V16,4 ракета покинет солнечную систему.

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.
Результат представить в виде таблицы, первый столбец которой — значения
аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"

1)Найдите сумму натуральных нечетных чисел не превышающих n!!!!Это нужно сделать циклом for. 2) Составьте программу,которая производит

суммирование произвольного количества целых чисел вводимых с клавиатуры.Концом последовательности служит ввод отрицательного числа.Программу составьте двумя способами: использую цикл с предусловием и цикл с постусловием



Вы находитесь на странице вопроса "Составьте", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.