Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дано действительное число x. Вычислить:

10-11 класс

(x-1)(x-3)(x-7)...(x-63)/(x-2)(x-4)(x-8)...(x-64)
pascal abc
Вот как моя программа выглядит, но она не работает.
program fggt;
var a,b,o,x:real;
begin
writeln('x');
readln(x);
a:=1;
b:=2;
while a<=63 do
begin
o:=(x-a)/(x-b);
a:=a-1;
b:=b*2;
end;
writeln('o=',o);
end.


Калядина1998 18 дек. 2014 г., 13:18:55 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sofyatulyakova
18 дек. 2014 г., 14:51:19 (9 лет назад)

Не мудрствуйте лукаво:)

var

  x, p, l: real;
  i: integer;
begin
  p := 1; l := 1;
  for i := 1 to 64 do
    if (i mod 2 = 1) then
      p := p * (x - i) //Числитель
    else
      l := l * (x - i); //Знаменатель
  writeln(p / l);
end.

Ответить

Другие вопросы из категории

программирование С++

очень очень нужно, пожалуйста напишите Т^Т

Написать программу, которая предлагает пользователю выбрать его знак
зодиака и в ответ печатает на экране краткий гороскоп. (Switch)


Помогите решить.Заранее спасибо=) 1. Для какого числа Х истинно высказывание: ¬ ((Х > 3) (Х > 4)) ?

2. Для какого числа Х истинно высказывание: ((Х > 2) V (Х < 2)) (Х > 4)) ?

Читайте также

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

СРОЧНО ПЛИИИЗ Задача: Дано действительное число Х, вычислить

(x-1)(x-3)(x-7)...(x-63)/(x-2)(x-4)(x-8)...(x-64) (дробь)

Используя оператор: while
Не могу написать через данный оператор программу на паскаль, выходит всегда число 0. Прошу помочь мне :)

на СИ,пожалуйста

Дано действительное число а.Вычислить выражение
(а-2)(а-4)(а-8)...(а-64):(а-1)(а-3)(а-7)...(а-63)

Создать программу на Паскале.

Даны
действительные числа х, у, и z. Вычислить
max (x + y + z, xyz).

(только пожалуйста напишите полное решение, а не кусок)



Вы находитесь на странице вопроса "Дано действительное число x. Вычислить:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.