Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Составьте программу, которая для одномерного массива, содержащего n элементов вычисляет и отображает: 1) сумму элементов массива; 2)произведение чётных

10-11 класс

элементов; 3) сумму элементов которые делятся на 3; 4) минимальный и максимальный элемент. (используя procedure или function, но чтоб была рекурсия)ПОЖАЛУЙСТА ПОМОГИТЕ ВОПРОС ЖИЗНИ И СМЕРТИ!!

Anton504540 28 апр. 2013 г., 6:25:31 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Estonia
28 апр. 2013 г., 8:43:20 (11 лет назад)

program massiv;

var a:array[1..10000] of longint; i,n,produs,summa, sum3, min, max: longint;

function produs(n:longint):longint;

begin

  produs:=1;

  for i:=1 to n do produs:=produs*a[i];

end;

function divna3(n:longint):longint;

begin

   for i:=1 to n do

     if a[i] div 3 = 0 then divna3:=divna3+a[i];

end;

procedure minMax(min,max:longint);

begin

  min:=a[1]; max:=a[1];

   for i:=1 to n do

    if a[i]>max then max:=a[i] else

       if a[i]<min then min:=a[i];

end;

begin

  writeln('daite N, n<10000'); readln(n);

  for i:=1 to n do

   begin

     readln(a[i]); summa:=summa+a[i];

   end;

 

 writeln('proizvedenie: ',produs(n));

 writeln('summa elementov: ',summa);

 writeln('summa elementov chto delytsya na 3: ', divna3(n));

writeln('min, max: ', minMax(min,max));

readln;

end.

 

Ответить

Другие вопросы из категории

1 мегобайт на гигобайт
1. Что такое приложение в среде Windows? как приложение связано с типом файла в среде Windows?

2.Что такое значок ? Какого типа значки существуют в определенной системе Windows?
3. Объяснить значение следующих ключевых понятий :
1)Задача
2)Диалоговое окно
3)Папка "МОЙ КОМПЬЮТЕР"

Читайте также

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

1.Составить программу, которая увеличивает каждый элемент настоящей таблице х [1 .. 10] на 1. 2. составить программу, замены положительных

элементов настоящей таблице х [1 .. 10] на 0.

3.составить программу, замены отрицательного элементов настоящей таблице х [1 .. 10] на их квадрат.

4.составить прогрумму, которая увеличивает на 2 все элементы настоящей таблице х [1 .. 10], которые больше 10.

1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115

2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150
3)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N

------------------------ОПЕРАТОР WHILE

Составить программу, которая формирует файл записей, содержащих информацию об автомобиле (название модели, год выпуска, цена, цвет), а также найти в

массиве записей и вывести на экран названия моделей красного цвета, випускалиcя в 2000 году.

P.s Помогите пожалуйста, заране огромное спасибо.



Вы находитесь на странице вопроса "Составьте программу, которая для одномерного массива, содержащего n элементов вычисляет и отображает: 1) сумму элементов массива; 2)произведение чётных", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.