Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Среди 20 вводимых чисел выберите все кратные 2 или кратные 5 и подсчитайте их сумму. (В Паскале)

10-11 класс

Iuraiariema03 23 февр. 2015 г., 5:32:18 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Damiraaydin
23 февр. 2015 г., 6:40:00 (9 лет назад)

var a:array[1..10] of integer;
s,s1:longint;
i,n:integer;
begin
n:=20;
s:=0; s1:=0;
for i:=1 to n do
begin
writeln('Vvedite element ',i);
read(a[i]);
end;
for i:=1 to n do
begin
write(a[i]:4);
end;
writeln;
for i:=1 to n do
begin
begin
if (a[i] mod 2=0) then s:=s+a[i];
end;
begin
if (a[i] mod 5=0) then s1:=s1+a[i];
end;
end;
writeln('Summa kratnix 2 = ',s);
writeln('Summa kratnix 5 = ',s1);
end.

Ответить

Другие вопросы из категории

Человек покупает коня, но недоволен ценой в 1000 рублей. Продавец ему предлагает платить не за коня, а за подковные гвозди: копейка за первый, две за

второй, четыре за третий и так далее (за каждый следующий гвоздь в два раза больше, чем за предыдущий). На покупку скольких гвоздей у покупателя хватит имеющихся у него 1000 рублей? Известно, что в каждой подкове по 6 гвоздей.

А1.

К осязательным знакам можно отнести:
1.устную речь, звон колокола.
2.азбуку Брайля
3.знаки химических элементов, дорожные знаки
4.запах шерсти
А2.
Алфавит, на котором строится единая система хранения и передачи наследственной информации живыми организмами: Выберите один из 4 вариантов ответа:
1) естественный
2) формальный
3) генетический
4) двоичный

Калькулятор для инопланетян работает в четверичной системе

счисления и для вывода числа на экран имеет только четыре знакоместа. С каким
самым большим числом они могут работать?
Ответ запишите в десятичной системе счисления. В ответе запишите только число,
не указывая основание.

Читайте также

Язык "Паскаль АВС" 1.Среди двухзначных чисел найти количество четных чисел. 2. Среди двухзначных чисел найдите те числа, у которых первая цифра четная.

3. Среди двухзначных чисел найдите те числа, которые кратны 3 и 4. 4. Среди трехзначных чисел найдите те, у которых все цифры равны. 5. Найдите среди трехзначных чисел симметричные числа. 6. Найдите среди четырехзначных чисел симметричные числа. 7. Найдите все трехзначные числа такие, что сумма цифр равна А, а само число делится на В. А и В вводятся с клавиатуры. 8. Найдите все трехзначные числа такие, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. 9. Найдите количество трехзначных чисел, сумма цифр которых равна А, а само число заканчивается на В, А и В вводятся с клавиатуры. 10. Найдите все трехзначные числа, у которых сумма крайних цифр равна сумме средних цифр, а само число делится на 6 и 27. 11.Найдите все трехзначные числа, которые при делении на 2 дают остаток 1, при делении на 3-остаток 2, при делении на 4-остаток 3, само число делится на5. 12. Найдите все четырехзначные числа, в которых есть две одинаковые цифры. 13. Найдите сумму всех чисел из промежутка от А до В, кратных 13 и 5, А и В вводятся с клавиатуры. 14. Найдите все симметричные четырехзначные числа. 15.Найдите все трехзначные числа, которые состоят из различных цифр, а их сумма равна А.

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если все числа не превышают 30, то выведите их

удвоенное произведение. Если последнее число четно, то выведите произведение первых двух чисел, уменьшенное в 10 раз.
Решить нужно на среде С или С++
Заранее спасибо.

помогите написать программы на паскале 1.вычислить произведение 3-х вводимых чисел которые меньше 20. 2. вывести на экран

количество четных и количество нечетных чисел в диапазоне от Х до У.



Вы находитесь на странице вопроса "Среди 20 вводимых чисел выберите все кратные 2 или кратные 5 и подсчитайте их сумму. (В Паскале)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.