Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Как проверять на четность НОМЕРА элементов массива?! for i:=1 to N do begin if (i mod 2 = 0) and (i <> 1) then

5-9 класс

a:=a+a[iMin]; write(f2,a,' ',' ',' ',' '); end;

к единице все равно прибавляется, почему? А надо чтобы только к четным

Olya0000 10 июня 2016 г., 20:00:40 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vanessamorga
10 июня 2016 г., 21:04:40 (7 лет назад)

Напиши вот так 

 

 

for i:=1 to N do

begin
   if (i mod 2 = 0) then   
    a:=a+a[iMin]; write(f2,a,' ',' ',' ',' ');

end; 

Ответить

Другие вопросы из категории

Плииз помогите))))))

Использую операторы цикла, напишите код программы, которая будет вычислять значение функции y=3x-1 при значениях х=1,2,3,4,5,

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число минимальное чётное число. Программа получает на вход

количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется чётное число. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – минимальное чётное число.

Читайте также

1. Указать ошибки в описании массива и пути их исправления: var a:array[real] of integer;

2. Определить,что распечатает следующая программа:
var a: array[1..5,1..5]of integer,i,j; integer;
begin
for i:=1 to 5 do begin
for j:=1 to 5 do begin
if i=5-j+1 then a[i,j]:=0
else a [i,j]:=0;
write(a[i,j]:2);
end;
writeln;
end; end.
3. Дан линейный массив a [l..n], содержащий целые числа. Вычислить сумму чисел делящихся одновременно на 5 и на 3 и распечатать номера таких чисел
4.Дан линейный массив a [l..n], содержащий целые числа. Преобразовать элементы массива по следующему правилу : если элемент положительный,то заменить его на 1, а если отрицательный - возвести в квадрат

Значение двух массивов А {1..100} и B {1..100} задаются с помощью следующего фрагмента программы:for n:=1 to 100 do A

{n} := (n-80)*(n-80);

for n:=1 to 100 do

B {101-n} :=A {n};

Какой элемент массива В будет наибольшим?

1) В {1} 2) B {21} 3) B {80} 4) B {100}

(вставлять только туда где есть ____) Заполните пропуски в программе ввода и вывода 10 целочисленных элементов массива, заданных случайным образом на

промежутке [20; 40]: Var A: array [1 . . _____] of integer; i: integer; Begin for i:=1 to _____ do begin A [ i ] : = random (_____) + ______; end; End.

вывести на экран номер всех счастливых билетов и подсчитать сколько их? В чем ошибка?

var a,b,c,d,f,e,n:longint; k:real;begink:=0;for n:=000001 to 999999 do begin a:= n mod 10;b:= n div 10 mod 10;c:= n div 100 mod 10;d:= n div 1000 mod 10;f:= n div 10000 mod 10;e:= n div 100000 mod 10;if(a+b+c=d+f+e) then begin writeln(n);k:=k+1;end;end;end.
покупатель должен заплатить в кассу S рублей . У него есть купюры в 1,2,5,10,50,100,500 руб. Найти наименьшее кол-во , которым он может рассчитаться? Помогите пожалуйста!



Вы находитесь на странице вопроса "Как проверять на четность НОМЕРА элементов массива?! for i:=1 to N do begin if (i mod 2 = 0) and (i <> 1) then", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.