Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дан массив целых чисел из 12 элементов. Поменять местами первый отрицательный с первым положительным.

10-11 класс

чикано 10 мая 2013 г., 16:31:51 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Aigizakberov
10 мая 2013 г., 18:51:43 (10 лет назад)

var a: array[1..12] of integer;
i,z: integer;
f:boolean;
begin
for i:=1 to n do 
readln(a[i]);
z:=a[1];
f:=false;
for i:=2 to 12 do
if not (f) and a[i]*a[1] then begin
a[1]:=a[i];
a[i]:=z;
f:=true;
end;
for i:=1 to 12 do
write(a[i], ' ');
end.
















+ 0 -
котик1999котоооо
10 мая 2013 г., 20:30:15 (10 лет назад)

язык ?

+ 0 -
Oaplaymarket615
10 мая 2013 г., 22:15:38 (10 лет назад)

Pascal

Ответить

Другие вопросы из категории

Читайте также

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Дан массив целых чисел из 15 элементов, заполненный случайным образом числами из промежутка [ -20, 50 ].

Удалить из него все элементы, в записи которых есть цифра 5.
Вставить число k после всех элементов, кратных своему номеру (k вводится с клавиатуры).
Поменять местами первый положительный и последний отрицательный элементы.

Дан массив целых чисел из n элементов, заполненный случайным образом числами из промежутка [-10,20].

Найти номер первого отрицательного элемента, делящегося на 5 с остатком 2.напишите пожалуйста программу в лазарусе



Вы находитесь на странице вопроса "Дан массив целых чисел из 12 элементов. Поменять местами первый отрицательный с первым положительным.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.