Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Составить алгоритм, который определяет сумму четных

10-11 класс

чисел из трех введенных a,b,c. Если таких нет, то вывести
сообщение об этом. (Можно с объяснением пожалуйста)

1СЕРГЕЙ555 25 марта 2017 г., 21:58:26 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ralk
25 марта 2017 г., 23:48:32 (7 лет назад)

var a,b,c,s:integer;//объявляем переменные
begin s:=0;//инициализируем s 
readln(a,b,c);//вводим a,b,c 
if a mod 2=0 then s:=s+a//если а делится на 2 без остатка то прибавляем а
 else if b mod 2=0 then s:=s+b//то же с b   
  else if c mod 2=0 then begin s:=s+c;//то же с c  
    writeln(s);//вывод s
    end
   else writeln('Нет');//если нет чётных выводим сообщение
end.    

+ 0 -
Sergeyx1997
26 марта 2017 г., 2:19:32 (7 лет назад)

var a,b,c,d:integer;
begin
writeln('Введите числа');
readln(a,b,c);
if (a mod 2=0) then d:=a;
if (b mod 2=0) then d:=d+b;
if (c mod 2=0) then d:=d+c;
if d<>0 then writeln('Сумма чётных чисел равняется ',d)
else writeln('Нет чётных чисел');
end.

Ответить

Читайте также

помогите решить задачки по Паскалю "4": Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее

использования. Пример: Введите число: 100 сумма = 5050

"5":

Составить функцию, которая определяет, сколько зерен попросил положить на N-ую клетку изобретатель шахмат (на 1-ую – 1 зерно, на 2-ую – 2 зерна, на 3-ю – 4 зерна, …) Пример: Введите номер клетки: 28 На 28-ой клетке 134217728 зерен.

1) Составить функцию, которая определяет наибольшее из трех чисел и привести пример ее использования. Пример: Введите три числа:

28 15 10

Наибольшее число: 28

2)Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее использования.

Пример:

Введите число:

100

Сумма = 500

Буду очень признателен за помощь.

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

Гражданин в первый день месяца открыл счет в банке,вложив,например,1000 долларов(S).Через каждый месяц(m) размер вклада увеличивался на 10% от всей

имеющейся суммы . Составить программу,которая определяет сумму вклада через n месяцев



Вы находитесь на странице вопроса "Составить алгоритм, который определяет сумму четных", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.