Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

произвести обращение массива не используя дополнительных массивов

10-11 класс

ЛеРуНдЕлЬ243 22 нояб. 2014 г., 12:53:36 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kibоrg
22 нояб. 2014 г., 14:45:18 (9 лет назад)

var

  a:array[1..100] of real;

  t:real;

  i, n:integer;

begin

  randomize;

  write('n = '); readln(n);

  writeln('Исходный массив');

  for i := 1 to n do

  begin

    a[i] := random(21) - 10;

    write(a[i], ' ');

  end;

  writeln;

  writeln('Преобразованный массив');

  for i := 1 to n div 2 do

  begin

    t := a[i];

    a[i] := a[n - i + 1];

    a[n - i + 1] := t;

  end;

 for i := 1 to n do

   write(a[i], ' ');

  writeln;

end.

Ответить

Другие вопросы из категории

срочно!!! по братски.....
сложить слово из букв.РНЕПИТР
СРОЧНО

Составьте программу, в которой функция выведет на экран однозначные числа, удовлетворяющие следующему условию: х*х*х-х*х=n , где n вводится с клавиатуры.

Читайте также

Помогите решить, очень нужно... 2. Составьте блок-схему алгоритма(её не надо) и программу вычисления в массиве A(10) количества положительных

элементов.
3. Составьте программу заполнения массива, не используя клавиатуру, числами: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19.

1. Составьте программу ввода и вывода массива: 5, -2, 3, -6, 7, 9, -4, 8, 1, 2, 7, -3.

2. Составьте блок-схему алгоритма и программу вычисления в массиве A(10) количества положительных элементов.
3*. Составьте программу заполнения массива, не используя клавиатуру, числами: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19.

Ребята,срочно помогите!)Даю 100 баллов.Составить алгоритм решения задачи на языке C++ . В отчете предоставить три программы с разными операторами

цикла (do ...while, while, for). В алгоритме и программе массивов не использовать.

Я здесь набросал все ,что мог, помогите доработать, написать до конца все эти операторы в одну программу,не получается.

#include <iostream>
#include <cstdlib>
#include <conio.h>
#include <math.h>

using namespace std;
int main()
{
float a,z,xn,xk,dx,R,max,min; float count=0,x;
a = 2.94;xn = 1.5;xk = 5.5;dx = 0.4;
while (xn <= xk)

for (x >= xn; x <= xk; x+=dx, dx = dx + 0.4)
{
do
{
z = a*pow((a*x*x*x*x*x*x*x/cos(a*a*a)+1,31),(1/5));
printf("X = %10f, Z = %10f \n", x, z);
dx = dx + 0.4;
}
while (x <= xk);
return 0;
}
{
max = x;min = z;
if (x > max) max = x;
if (z < max) min = z;
if (count > 2) count = 0;
if (count == 2) printf("X = %10f, Z = %10f \n", x, z);
count=0;
}
cout<<"max="<<max<<"\t min="<<min<<"\n";
cout<<"R="<<min-max<<"\n";
system("PAUSE");
return 0;
}



Вы находитесь на странице вопроса "произвести обращение массива не используя дополнительных массивов", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.