Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Задача 1 Какое число будет выведено на экран последним?Данцикл: I:=1;While I<=17 To begin writeln (I:5);

5-9 класс

>

I:=I+5;

End;

Writeln (I:5);

тема паскаль

Еврей1111 22 авг. 2015 г., 19:07:26 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Uliya18
22 авг. 2015 г., 20:48:36 (8 лет назад)

Будет выведено число 21.

 

I цикл: 1, 1<=17; i:=1+5=6.

II цикл: 6, 6<=17, i:=6+5=11.

III цикл: 11, 11<=17, i:=11+5=16.

 

IV цикл: 16, 16<=17, i:=16+5=21.

 

Дальше цикл не пойдет, т.к. 21>17.

 

Ответить

Другие вопросы из категории

1.Стремясь усилить воздействие на все органы чувств человека во время просмотра кинофильмов, люди придумали 3D, 4D и даже 7D кинотеатры. Какая

информация не воспринимается человеком при данных просмотрах?
1) Тактильная
2) Обонятельная
3) Вкусовая
4) Слуховая
2.Найди лишнее:
1) facebook
2) Linked in
3) в контакте
4) @
3.Какой предмет является лишним ( по ризнаку - управлять курсором)?
1) компьютерная мышь
2) джостик
3)диск
4)клавиатура
4.

Помогите, пожалуйста



Задание: записать условия на языке
Pascal.



Каждое
из чисел А и В больше 100


Только одно
из чисел А и В четное.



Хотя бы
одно из чисел А и В положительно.


Каждое из
чисел A, B, C меньше 50.

Читайте также

ДАЮ 40 БАЛЛОВ! ПОМОГИТЕ ПОЖАЛУЙСТА!

1.Какое число будет выведено на экран после выполнения этого фрагмента программы?
write(1);
for i:=2 to 1 do
write (i);

2.Что будет выведено на экран в результате выполнения фрагмента программы
a:=5; b:=3;
write( a, '=Z(', b, ')' );
Здесь a и b — целые переменные.

3.Что будет выведено на экран в результате выполнения фрагмента программы
a:=5; b:=3;
write( 'Z(a)=', '(b)' );
Здесь a и b — целые переменные.

1 Задание:сформируйте и выведите на экран массив из девяти элементов,каждые три последовательных элемента которого составлены по следующему правилу:

1-й равен значению текущего индекса, увеличенному на 3; 2-й равен квадрату предыдущего индекса; 3-й равен сумме двух предыдущих элементов. 2 Задание : сформируйте массив, содержащий 15 элементов ,с помощью датчику случайных чисел. Получите новый массив,каждый элемент которого равен сумме соответствующего элемента исходного массива и его индекса. В полученном массиве удвойте элементы,которые меньше заданного с клавиатуры числа А,и найдите их сумму . Выведите на экран исходные и полученные результаты .

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

Дан фрагмент программы :

a:= 10 ; b:= a+1 : a:=b-a ; write (a,b)
Какие числа будут выведены на экран компьютера ?



Вы находитесь на странице вопроса "Задача 1 Какое число будет выведено на экран последним?Данцикл: I:=1;While I&lt;=17 To begin writeln (I:5);", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.