Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите , пожалуйста, с решением, в понедельник экзамен!!! Напишите программу для решения следующей задачи. Камера наблюдения

5-9 класс

регистрирует в автоматическом режиме скорость проезжающих мимо нее автомобилей, округляя значения скорости до целых чисел. Необходимо определить максимальную зарегистрированную скорость автомобиля. Если скорость хотя бы одного автомобиля была меньше 30 км/ч, выведи YES, иначе выведите NO. Программа получает на вход число проехавших автомобилей N ( 1 ≤ N ≤ 30), затем указываются их скорости. Значение скорости не может быть меньше 1 и больше 300. Программа должна сначала вывести максимальную скорость, затем YES или NO.

Пример работы программы:

Входные данные Выходные данные

4 74

74 NO

69

63

66

Маринамик 03 дек. 2016 г., 0:02:28 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vdvdsvf
03 дек. 2016 г., 1:20:47 (7 лет назад)

Program Nonenone;
uses crt;
var
  n,i:integer;
  max,v:real;
  yes: string;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  max:=0;
  yes:='NO';
  writeln('Введите количество машин (не больше 30 - у меня мало памяти!)');
  write('N = ');
  readln(n);
  if n>30 then
      writeln('Это слишком много!')
    else
      begin
        writeln('Вводите зарегистрированную скорость каждого автомобиля');
        for i:=1 to n do
          begin
            write(i,'-я машинка: ');
            readln (v);
            if v >300 then
                begin
                  writeln ('по-моему, твои приборы глючат - так быстро машины не ездят');
                  writeln ('Это число не будет учтено');
                end
              else
                begin  
                  if v<30 then yes:='YES';
                  if v>max then max:=v;
                end;
          end;
        writeln();
        writeln('Максимальная зарегистрированную скорость ',max);
        writeln('Cкорость меньше 30 км/ч? ',yes);
      end;
end.

Ответить

Другие вопросы из категории

Помогит пожалуйста с информатикой!7 класс) 1)Какое количество информации в сообщении из 50 символов,записанного буквами из 16-символьного

алфавита

2)сколько байт содержит 1 килобайт?А сколько это бит?

3)По какой формуле определяется количество информации? Количество информации в сообщении?

4)какое количество информации в Кбайте содержится в 2 Гбайтах?

5)В рулетке общее количество лунок равно 64. Какое количество информации мы получаем в зрительном сообщение об остановке шарика в одной из лунок?

Проблема такая:

нужна правильно выполненная задача в формате Паскаль!Помогите пожалуйста!!!!!!

Читайте также

Помогите пожалуйста,не понимаю эту тему("Составление и исполнение алгоритмов линейной структуры.")

Напишите программы для ниже указанных задач:
-Найдите периметр трапеции, длины всех сторон которой вводятся с клавиатуры.
-Найдите стоимость заданного количества ткани.Цена и количество вводятся с клавиатуры.
-Найдите путь, пройденный автомобилем за заданное время.Значение средней скорости и время движения вводятся с клавиатуры.

напишите программу в Паскаль чтобы нарисован был светофор)) небольшой, разрисован нужными цветами( жёлтый, зелёный, красный) и сам светофор

серый..Помогите пожалуйста...ставлю спасибо))) надеюсь на вашу помощь)))( программу не большую)

Напишите программу для угадывания слова. Она должна запрашивать от

пользователя строки, пока тот не введет слово, предусмотренное в программе.
Помогите,пожалуйста

напишите программу в Паскаль чтобы нарисован был светофор)) небольшой, разрисован нужными цветами( жёлтый, зелёный, красный) и сам светофор

серый..Помогите пожалуйста...ставлю спасибо))) надеюсь на вашу помощь)))( программу не большую)

Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округ

ляя значения скорости до целых чисел. Необходимо определить максимальную зарегистрированную скорость автомобиля. Если скорость хотя бы одного автомобиля была меньше 30 км\ч, выведите YES, иначе выведите NO.

Программа получает на вход число проехавших автомобилей N (1=<N=<30), затем указывает их скорости. Значение скорости не может быть меньше 1 и больше 300.

Программа должна сначала вывести максимальную скорость, затем YES или NO.

Написать на языке Паскаль

Пример работы программы: (смотри во вложениях)



Вы находитесь на странице вопроса "помогите , пожалуйста, с решением, в понедельник экзамен!!! Напишите программу для решения следующей задачи. Камера наблюдения", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.