Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

дана последовательность целых чисел а1,а2,..,а20. верно элементы последовательности равны собой.нужно написать программу на паскале с циклом

5-9 класс

Taninivan 02 сент. 2014 г., 13:34:38 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dinka1406
02 сент. 2014 г., 14:40:13 (9 лет назад)

var a: array [1..20] of integer;
    i: integer;
begin
     for i := 1 to 20 do
         readln(a[i]);
     for i := 1 to 20 do
         if (a[i] <> a[1]) then
         begin
              writeln('Неверно');
              exit;
         end;
     writeln('Верно');
end.

Надеюсь, я правильно понял задачу, а то иногда не разобрать... Тут вначале надо 20 чисел ввести, а потом она проверяет, верно ли, что они все равны)

Ответить

Другие вопросы из категории

1. Запишите 10 чисел, следующих за числом 11001012,

в двоичной системе счисления.

Человек способен различить примерно 100 градаций яркости.Сколько бит необходимо,чтобы закодировать конкретное значение яркости?

Дискеты распространённые в конце 90-годов имели объем 1440 Кбайт и весили всего 20 г.Расчитайте,сколько будет весить набор таких дискет,необходимый для полного копирования информации с жесткого диска объемом 1 Тбайт?

Фирма"Электронные приборы" выпустила автоматизированную ванну "Банный комплекс-10",управляемую с помощью 10 кнопок: "долить 1л", "долить 2 л",...,

"долить 5 л", "слить 1 л", "слить 2 л",... , "слить 5 л", при нажатии на которые доливается или сливается указанное количество литров воды. Однако в результате ошибки фирмы все кнопки, кроме "долить 5 л" и "слить 3 л", не работают. Необходимо, используя эти две кнопки долить в ванную 3 л воды. Сколько воды при этом пропадет впустую из-за брака фирмы? (впиши полученное число в форму под этим вопросом, единицы измерения указывать не нужно)

Читайте также

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

НУЖНО НАПИСАТЬ ПРОГРАММЫ НА ПАСКАЛЕ "циклы с условием" 1)Среди чисел 1, 4. 9. 16, 25,... найти первое число, большее n. 2)Дано число

n.

а) Напечатать те натуральные числа, квадрат которых не превышает n.

3) Дано натуральное число. Определить:

а) количество цифр 3 в нем;

г) сумму его цифр, больших пяти;



Вы находитесь на странице вопроса "дана последовательность целых чисел а1,а2,..,а20. верно элементы последовательности равны собой.нужно написать программу на паскале с циклом", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.