Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Ввести

5-9 класс

c клавиатуры
массив из 5 элементов, найти минимальный из них.

Елизавееееета 02 авг. 2013 г., 22:49:59 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
0106061
03 авг. 2013 г., 1:19:39 (10 лет назад)

var
   A:array [1..5] of integer;
   i,min,s:integer;
begin
   for i:= 1 to 5 do
   begin
      write('Введите ',i,' элемент массива: ');
      readln(A[i]);
   end;
   min:=A[1];
   s:=0;
   write('Введенный массив: ');
   for i:= 1 to 5 do
   begin
      write(A[i]:4);
      if A[i]<min then min:=A[i];
      s:=s+A[i];
      A[i]:=A[i]*2;
  end;
  writeln;
  writeln('Минимальный элемент массива = ',min);
  write('Удвоенные значиния элементов массива: ');
  for i:= 1 to 5 do write(A[i]:4);
  writeln;
  writeln('Среднее арифметическое элементов массива = ',s/5);
  end.

Ответить

Другие вопросы из категории

Помогите пожалуйсто

Какие из приведенных ниже чисел записанных в пятеричной системе счисления будут деиться на 3 без остатка ?
а) 44
б) 142
в) 12
г )41

В оперативной памяти компьютера хранится

1 только программы
2 программы и данные
3 только данные
4 файлы

Читайте также

На вход программы, приведенной ниже, поданы два числа: 1 и 3. Ввести x и y; x=y-x y=2*x x=2*y+x y=y+x/2

Ввести x и y

Какие значения будут выведены в результате ее работы?

1)составьте программу ,которая предлагает ввести с клавиатуры две строки ,а затем выводит это строки на экран в алфавитном порядке

например армия(строка а)
арбуз (строка б)
2)составьте программу ,которая предлагает ввести с клавиатуры две строки а и б ,соеденяет их и выводит результат в одну строку
например: тепло(строка а)
ход(строка б)

1)В поезде 17 вагонов, 10-17-купейные, остальные-плацкарт.Ввести № вагона.напечатать вид.

2)Ввести 2 числа. Напечатать их частное или сообщить, что на 0 делить нельзя

Программу надо написать в PascalABC, с использованием команд repeat и until. Ввести натуральное число и определить, какие цифры встречаются несколько раз

(с защитой от неверного ввода) или Ввести натуральное число и определить, верно ли, что сумма его цифр равна 10 (с защитой от неверного ввода).



Вы находитесь на странице вопроса "Ввести", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.