Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

сформулируйте массив,содержащий 15 элементов,с помощью датчика случайных чисел. получите новый массив,каждый элемент которого равен обратному

5-9 класс

соответствующему элементу исходного массива. посчитайте кол- во неизменившихся эелементов и найдите в новом массиве максимальный о абсолютной величине отрицательный элемент. выведите на экран исходные и полученные результаты (ПОМОГИТЕ ПОЖЛСТ ОЧЕНЬ НАДО)

123love123 24 апр. 2014 г., 13:59:04 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Onlyi
24 апр. 2014 г., 15:30:12 (10 лет назад)

Program n1;
Uses CRT;
Const n=15;
Var A: array[1..n] of integer; B: array[1..n] of integer;
i,k,max: integer;
begin
randomize;
clrscr;
Writeln('ishodny massiv');
For i:=1 to n do
begin
a[i]:=random(100);
a[i]:=a[i]-50;
write(a[i]:4);
end;
writeln;
writeln('polychenny massiv');
max:=0;
For i:=1 to n do
begin
b[i]:=-a[i];
write(b[i]:4);
If a[i]=b[i] then k:=k+1;
If (b[i]>0)and(b[i]>max) then max:=b[i];
If (b[i]<0)and(-b[i]>max) then max:=-b[i];
end;
writeln;
Writeln('Kolychestvo neizmenyvshihsa elementov=',k,', samyi bolshoy po modyly element raven =',max);
writeln
end.

Ответить

Другие вопросы из категории

Срочно!!!! помогите!!!!
Пословицы, поговорки, крылатые выражения являются своеобразными моделями, которые мы используем в речи для придания ей образности и

эмоциональности. Прочитайте истории возникновения поговорок и опишите современные ситуации, моделями которых они служат.

Читайте также

I В паскале с помощью генератора случайных чисел получить двузначное число и

1) найти и вывести сумму его цифр
2) сформировать число, в котором поменяются разряды (допустим будет число 13, нужно сделать, что бы было 31 и т.п.)
II В паскале с помощью генератора случайных чисел получить трехзначное число и определить, является ли оно полимером (например 121 - является, 123 - нет)

I В паскале с помощью генератора случайных чисел получить двузначное число и

1) найти и вывести сумму его цифр
2) сформировать число, в котором поменяются разряды (допустим будет число 13, нужно сделать, что бы было 31 и т.п.)
II В паскале с помощью генератора случайных чисел получить трехзначное число и определить, является ли оно полимером (например 121 - является, 123 - нет)

Последняя задача...если вы мне поможете,то в аттестате 4 будет....пожалуйста помогите.вот:Сформируйте массив содержащий 15 элементов,с помощью датчика

случайных чисел.Получите новый массив,каждый элемент которого равен удвоенному соответствующему элементу исходного массива.В полученном массиве найдите максимальный элемент среди элементов,номера которых кратны трем.Выведите на экран исходные и полученные результаты

Сформируйте массив, содержащий 15 элементов с помощью датчика случаных чисел; получите новый массив, каждый элемент которого равен разности

квадрата и самого соответствующего элемента исходного массива. найдите резность сумм элементов исходного и нового массива. Выведите на экран исходный и поулченные результаты.

Спасибо заранее

(Pascal) Задача:

Дан массив из 8 элементов, с помощью датчика случайных чисел посчитать количество нечётных элементов.



Вы находитесь на странице вопроса "сформулируйте массив,содержащий 15 элементов,с помощью датчика случайных чисел. получите новый массив,каждый элемент которого равен обратному", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.