Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

помагите из 20 элементов найти максимальный элемент

5-9 класс

Sidtim 07 дек. 2014 г., 15:32:38 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nadezhdasobole
07 дек. 2014 г., 16:17:40 (9 лет назад)

#include <stdio.h>
#include <conio.h>
const int N=10;
clrscr;
main()
{int Max,index,i,A[N];
printf("vvedi massiv\n");
for(i=0;i<N;i++)
{printf("vvedite A[%d]=",i);
scanf("%d",&A[i]);
}
Max=A[0]; index=0;
for(i=1;i<N;i++)
{
if(A[i]>Max)
{
Max=A[i]; index=i;
}
}
printf("\n max ravno %d",Max);
printf("\n index raven %d",index);

}

+ 0 -
NoyN1ka
07 дек. 2014 г., 17:38:52 (9 лет назад)

Предоставлю решение на Pascal

Program Zn;
const N=21;
var m:array[1..N] of integer;
max,i:integer;
Begin
max:=-30000;
For i:=11 to N do begin
Writeln('Введите эллемент массива');
Readln(m[i]);
if max<m[i] then max:=m[i]
end;
writeln('Максимальный эллемент массива=',max);
end.

(Проверено и от компелировано на Pascal.NET)

Ответить

Другие вопросы из категории

крестьянину было предложено взять столько земли,сколько он успеет обежать по замкнутому контру в течение одного дня.Ему выгодно бежать по маршруту

,пролегающему по :

1)прямой

2)сторонам треугольника

3)сторонам квадрата

4)окружности

5)сторонам шестиугольника

Читайте также

1) Удвоить все элементы массива. 2)Найти сумму элементов двух массивов одинаковой размерности. 4) Найти Минимальные элементы массива и

его индекс.

5) Найти максимальные элементы среди положительных элементов массива 6) Найти максимальные элементы среди отрицательных элементов массива

7) Определить количество максимальных элементов массива

P.S Ребят, все в паскале...заранее спасибо=*

Напишите программу, которая находит в матрице столбцы, в которых есть элемент, равный максимальному.

Входные данные
В первой строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M ( 1 ≤ N , M ≤ 100 ). В следующих N строках записаны строки матрицы, в каждой – по M натуральных чисел, разделённых пробелами.

Выходные данные
Программа должна вывести все столбцы, в которых есть элемент, равный максимальному элементу в матрице. Каждый столбец выводится в одну строку, элементы разделяются пробелами.



Вы находитесь на странице вопроса "помагите из 20 элементов найти максимальный элемент", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.