Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

1) В массиве 40 элементов. Найти максимальный элемент и на его место вставить предыдущий, а его на место предыдущего. 2) Перед минимальным

5-9 класс

элементом вставить 0.

HELP ! составьте программку))

у5гкн 10 сент. 2013 г., 20:11:15 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mirelka
10 сент. 2013 г., 21:29:38 (10 лет назад)

var
a:array[1..40] of integer;
i,max,min,mx,mn:integer;
begin
randomize;
mx:=1; mn:=1;
max:=-100;min:=100;
for i := 1 to 40 do
begin
a[i]:=100-random(201);
write(a[i],' ');
if a[i]>max then begin
max:=a[i];
mx:=i;
end;
if a[i]<min then begin
mn:=i;
min:=a[i];
end;
end;
writeln;
if mx>1 then
begin
a[mx]:=a[mx-1];
a[mx-1]:=max;
end;
for i := 1 to 40 do
if i = mn then
write('0 ',a[i],' ') else
write(a[i],' ');
end.

 

Ответить

Читайте также

1) Удвоить все элементы массива. 2)Найти сумму элементов двух массивов одинаковой размерности. 4) Найти Минимальные элементы массива и

его индекс.

5) Найти максимальные элементы среди положительных элементов массива 6) Найти максимальные элементы среди отрицательных элементов массива

7) Определить количество максимальных элементов массива

P.S Ребят, все в паскале...заранее спасибо=*

Напишите программу, которая находит в матрице столбцы, в которых есть элемент, равный максимальному.

Входные данные
В первой строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M ( 1 ≤ N , M ≤ 100 ). В следующих N строках записаны строки матрицы, в каждой – по M натуральных чисел, разделённых пробелами.

Выходные данные
Программа должна вывести все столбцы, в которых есть элемент, равный максимальному элементу в матрице. Каждый столбец выводится в одну строку, элементы разделяются пробелами.

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.



Вы находитесь на странице вопроса "1) В массиве 40 элементов. Найти максимальный элемент и на его место вставить предыдущий, а его на место предыдущего. 2) Перед минимальным", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.