Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Составить алгоритм на языке программирования , который выводит среднее арифметическое наибольшего и наименьшего из 20 элементов , имеющих значение из

5-9 класс

интервала [-10;10]

Masha0003 02 февр. 2015 г., 14:27:07 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Iammm
02 февр. 2015 г., 17:08:11 (9 лет назад)

pascal:
const n=20;
var a: array[1..n] of integer;
max, min, i: integer;
begin
max:=-11;
min:=11;
for i:=1 to n do begin
a[i]:=random(20)-10; {или readln(a[i]); если нужен конкретный ввод}
if a[i]>max then max:=a[i];
if a[i]<min then min:=a[i];
end;
writeln((max+min)/2);
end.

Ответить

Другие вопросы из категории

Определите количество цветов в палитре при глубине цвета 4, 8, 16, 24, 32 бита. В процессе

преобразования растрового графического изображения количество цветов увеличилось с 16 до 4294967296. Во сколько раз увеличился объем, занимаемый им в памяти

какие из чисел, представленных в двоичной,восьмеричной,десятичной шестнадцатеричной системах счисления меньше 150 в десятичной системе счисления?

1) 10111011 в двоичной
2) 46 в шестнадцатеричной
3) 314 в восьмеричной
4) 10010011 в двоичной
5) 3Е8 в шестнадцатеричной
6) 135 в восьмеричной


выберите три правельных ответа!

Читайте также

1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

из математической записи создать запись на языке программирования.

а)2,136+2/3y
б)(x-5)+a/3ax
Например:
Математическая запись: Запись на языке программирования:
a+3b-2c (a+3 умножить на b-2 умножить на c):(7 умножить на a+2)
Срочно!

Помогите!:с нужно составить алгоритм на языке программирования Паскаль.

Дан массив, состоящий из 10 элементов. Определите, сколько элементов этого массива имеют максимальное значение.



Вы находитесь на странице вопроса "Составить алгоритм на языке программирования , который выводит среднее арифметическое наибольшего и наименьшего из 20 элементов , имеющих значение из", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.