Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Здравствуйте! Помогите пожалуйста с информатикой в целом. Ничего не соображаю в паскале бейсике. не могу научиться строить алгоритмы к задачам по

10-11 класс

экономике, и вообще с трудом я в этой информатике. Буду благодарна, если кто-нибудь поможет мне с этой проблемой.

жор20 08 окт. 2015 г., 2:58:28 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
жек3333
08 окт. 2015 г., 4:59:49 (8 лет назад)

type
  Date = record
    d: integer;
    m: integer;
    y: integer
  end;

function kday(pd: Date): longint;
// Алгоритм 199б
// "Переход от календарной даты к порядковому номеру дня и обратно"
// взят из сборника // "Библиотека алгоритмов 151б-200б", М.И.Агеев и др.,
// М.: Радио и связь, 1981
//
// Алгоритм возвращает порядковый номер дня по Юлианскому календарю.
// Работает для дат, начиная с 01.01.4713 до н.э.
var
  c, ya: longint;
begin
  with pd do
  begin
    if m > 2 then m := m - 3
    else
    begin
      m := m + 9;
      y := y - 1
    end;
    c := y div 100;
    ya := y mod 100;
    Result := ((146097 * c) div 4) + ((1461 * ya) div 4) +
      ((153 * m + 2) div 5) + d + 1721119
  end;
end;

var
  d1, d2: Date;

begin
  Writeln('Введите первую дату в формате <день месяц год>: ');
  readln(d1.d, d1.m, d1.y);
  Writeln('Введите вторую дату в формате <день месяц год>: ');
  readln(d2.d, d2.m, d2.y);
  writeln('Между этим датами прошло дней: ',jday(d2) - jday(d1)); 
end.

+ 0 -
Edgarzed
08 окт. 2015 г., 7:22:43 (8 лет назад)

Комментарий удален

+ 0 -
DashaU
08 окт. 2015 г., 10:13:55 (8 лет назад)

Комментарий удален

+ 0 -
Ighnatchik
08 окт. 2015 г., 12:11:55 (8 лет назад)

к сожалению нет.

+ 0 -
Missma2312
08 окт. 2015 г., 13:03:47 (8 лет назад)

Комментарий удален

+ 0 -
Volobueva2647695589
08 окт. 2015 г., 14:32:31 (8 лет назад)

Давайте попробуем

Ответить

Другие вопросы из категории

Помогите пожалуйста!!!
Даны 2 двузначных целых числа X и y.Найти D=MAX{x+y;y-x}+3,E=MIN{x^2+y^2;y^2+x*y}-4.если D<E,то к переменной D прибавить первую цифру числа E,иначе

из числа взять корень степени,равной второй цифре числа.

Помогите,пожалуйста,написать программу в паскале ABC

Читайте также

помогите пожалуйста с информатикой!легкие задания,но не была на этой теме.

особенно обязательно вторые два задания.

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Здравствуйте, помогите, пожалуйста, составить программу. Задача-Сформулируйте и выведите на экран массив из 9 элементов, каждые три последовательных

элемента которого составлены по следующему правилу:
1-й равен квадрату текущего индекса, увеличенному на 5;
2-й равен целой части квадратного корня из предыдущего элемента;
3-й равен целой части от деления двух предыдущих элементов.

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ ПОЖАЛУЙСТА С ИНФОРМАТИКОЙ, НУ ПОЖАЛУЙСТА !!!!!

Производилась двухканальная (стерео) звукозапись с частотой
дискретизации 64 кГц и 16-битным разрешением. В результате был получен
файл размером 48 Мбайт, сжатие данных не производилось. Определите
приблизительно, сколько времени (в минутах) проводилась запись.
В качестве ответа укажите ближайшее к времени записи целое число.
Ответ: ___________________________



Вы находитесь на странице вопроса "Здравствуйте! Помогите пожалуйста с информатикой в целом. Ничего не соображаю в паскале бейсике. не могу научиться строить алгоритмы к задачам по", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.