Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

1.найдите ошибку в следующем фрагменте программы

5-9 класс

Var k:integer;x,y,i:real;
Begin y:=1
For I:=1 to 7 do y:=2*y
End

Irafil250880 07 окт. 2013 г., 14:42:04 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ричард
07 окт. 2013 г., 16:39:17 (10 лет назад)

переменная i не может быть типа real, т.к. счетчик может быть только целым числом
после y:=1 должна стоять ;
после End должна стоять точка

Ответить

Другие вопросы из категории

Помогите,пожалуйста с тестом по информатике! Это срочно! Даю 30 баллов!

1.Примером документальной базы данных является база данных,содержащая:
а)законодательные акты
б)Сведения о кадровом составе учреждения
в)Сведения о финансовом состоянии учреждения
2.База данных - это...
3.Примером иерархической базы данных является
а)Страница классного журнала
б)Каталог файлов,хранимых на диске
в)Расписание поездов
г)Электронная таблица
4.Наиболее точным аналогом реляционной базы данных может служить:
а) Неупорядоченное множество данных
б) Вектор
в) Генеалогическое древо
г) Двумерная таблица
5. Поля реляционной базы данных
а) Именуются пользователем произвольно с определенными ограничениями
б) Автоматически нумеруются
в) Именуются по правилам,специфичным для каждой конкретной СУБД
г) Нумеруются по правилам,специфичным для каждой конкретной СУБД
6.Структура реляционной базы данных меняется при удалении:
а) Одного из полей
б) Одной записи
в) Нескольких записей
г) Всех записей
7.В записи реляционной базы данных может содержаться:
а) Неоднородная информация(данные разных типов)
б) Исключительно однородная информация(данные только одного типа)
в) Только текстовая информация
г) Исключительно числовая информация
8. Значение выражения 0,7-3>2 относится к следующему типу данных:
а) Числовому
б) Логическому
в) Строковому
г) Целому
9. Система управления базами данных(СУБД) - это...
10. Модель отражает:
а) Все существующие признаки объекта
б) Некоторые из всех существующих
в) Существенные признаки в соответствии с целью моделирования
г) Некоторые существенные признаки объекта
д) Все существенные признаки
11. При описании отношений между элементами системы удобнее всего использовать информационную модель следующего типа:
а) Текстовую
б) Математическую
в) Структурную
г) Табличную
д) Графическую
12. Понятие модели имеет смысл при наличии:
а) Моделирующего субъекта и моделируемого объекта
б) Цели моделирования и моделируемого объекта
в) Моделирующего субъекта;цели моделирования и моделируемого объекта
г) Цели моделирования и двух различных объектов
д) Желания сохранить информацию об объекте
13. Рисунки,карты,чертежи,диаграммы,схемы,графики представляют собой модели следующего вида:
а) Табличные информационные
б) Математические модели
в) Натурные
г) Графические информационные
д) Иерархические информационные
14. Суть основного тезиса формализации состоит в принципиальной возможности:
а) Представления информации на материальном носителе
б) Передачи информации от одного объекта к другому
в) Обработка информации человеком
г) Хранение информации в памяти компьютера
д) Разделение объекта и его обозначения

написать программу,которая выводит на экран суммарный путь спортсмена за N дней тренировки.Если известно,что спортсмен,начав тренировку,в первый

день пробежал 5 км,каждый день он увеличивает дневную норму на 17% нормы предыдущего дня.ПОМОГИТЕ ПОЖАЛУЙСТА!!Желательно решение в 3 способах

Известно, что рисунок состоит из 1310720 пикселей и занимает целиком весь экран дисплея. Какова разрешающая

способность монитора (допускаются только стандартные размеры графической сетки)? Поясните свой ответ.

Составить программу в Паскале.

Даны стороны треугольника а,в,с.Найти его периметр.

Читайте также

Подробности от учителя:1.Определить значение переменной у после выполнения следующего фрагмента программы:

y:=1;
For i:=2 to 4 do y:=y+i;

2.Определить значение переменной у после выполнения следующего фрагмента программы:
y:=0;
For i:=-100 to 100 do
If i mod 10 =5 then y:=y+i;

3. На промежутке [a;b] (a,b -целые числа, которые вводятся с клавиатуры) определить среднее арифметическое чисел кратных 7

1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 6; 9; 7; 2; 1; 5; 0; 3; 4; 8 соответственно,

т.е. A[0] = 6; A[1] = 9 и т.д.
Определите значение переменной c после выполнения следующего фрагмента программы.

c := 0;
for i := 1 to 9 do
if A[i - 1] < A[i] then begin
c := c + 1;
t := A[i];
A[i] := A[i - 1];
A[i - 1] := t
end;

1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a := 3 + 8*4; b :=

(a div 10) + 14;

a := (b mod 10) + 2;

2) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 1819;

b := (a div 100)*10+9;

a := (10*b–a) mod 100;

3) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 42;

b := 14;

a := a div b;

b := a*b;

a := b div a;

4) Определите значение целочисленных переменных x, y и t после выполнения фрагмента программы:

x := 5;

y := 7;

t := x;

x := y mod x;

y := t;

5) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

а :=6*12 + 3;

b :=(a div 10)+ 5;

a :=(b mod 10)+ 1;

1)Определите значение с после выполнения следующего фрагмента программы а:= 100; b:=30; а:= а-b*3; if a>b then c:= а-b

else с:= b-a;

2) Чнму равна сумма элементов а{1} и а{4} массива, сформированного следующим образом.

for i:= 1 to 5 a{i} :=i*(i+1)



Вы находитесь на странице вопроса "1.найдите ошибку в следующем фрагменте программы", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.